HDU 4565 So Easy!(矩陣快速冪)

So Easy!
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1176 Accepted Submission(s): 348


Problem Description
  A sequence Sn is defined as:

Where a, b, n, m are positive integers.┌x┐is the ceil of x. For example, ┌3.14┐=4. You are to calculate Sn.
  You, a top coder, say: So easy!


Input
  There are several test cases, each test case in one line contains four positive integers: a, b, n, m. Where 0< a, m < 215, (a-1)2< b < a2, 0 < b, n < 231.The input will finish with the end of file.


Output
  For each the case, output an integer Sn.


Sample Input

2 3 1 2013

2 3 2 2013

2 2 1 2013




Sample Output

4

14

4




Source
2013 ACM-ICPC長沙賽區全國邀請賽——題目重現


Recommend

zhoujiaqi2010


題意:

已知a,b,n,m,求表達式的結果Sn。

思路:

1.由b的取值(a-1)2< b < a2,可得0<a-√b<1令Cn=(a+√b)^n+(a-√b)^n,左右兩項共軛,

可得Cn爲整數,則Cn=⌈(a+√b)^n⌉,Sn=(Cn)%m。

2.爲求解通項公式,對Cn乘上((a+√b)+(a-√b)),化簡可得Cn+1=2aCn(a2b)Cn1

3.將遞推式寫成矩陣形式,可得:[Cn+1Cn]=[2a1(a2b)0]n[C1C0]


/*************************************************************************
	> File Name: A.cpp
	> Author: BSlin
	> Mail:  
	> Created Time: 2013年09月20日 星期五 22時02分56秒
 ************************************************************************/

#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <cstdlib>
#include <cmath>
#include <algorithm>
#include <iterator>
#include <vector>
#include <map>
#include <set>
#include <stack>
#include <queue>
#define MP make_pair
#define INF (1<<30)
#define PI acos(-1.0)
#define esp 1e-8
const int dx[4]={0,0,0,0};
using namespace std;
#define read freopen("in.txt","r",stdin)
#define write freopen("out.txt","w",stdout)
#if defined (_WIN32) || defined (__WIN32) || defined (WIN32) || defined (__WIN32__)
#define LL __int64
#define LLS "%" "I" "6" "4" "d"
#else
#define LL long long
#define LLS "%" "l" "l" "d"
#endif



LL a[3][3],temp[3][3],sum[3][3];

void solve(LL n,LL mod) {
    int i,j,k;

    for(i=0;i<2;i++) {
        for(j=0;j<2;j++) {
            sum[i][j] = a[i][j];
        }
    }

    n--;

    while(n) {
        if(n&1) {
            for(i=0;i<2;i++) {
                for(j=0;j<2;j++) {
                    temp[i][j] = a[i][j];
                }
            }
            for(i=0;i<2;i++) {
                for(j=0;j<2;j++) {
                    a[i][j] = 0;
                    for(k=0;k<2;k++) {
                        a[i][j] = ((a[i][j] + temp[i][k] * sum[k][j]) % mod + mod) % mod;
                    }
                }
            }
        }
        for(i=0;i<2;i++) {
            for(j=0;j<2;j++) {
                temp[i][j] = sum[i][j];
            }
        }
        for(i=0;i<2;i++) {
            for(j=0;j<2;j++) {
                sum[i][j] = 0;
                for(k=0;k<2;k++) {
                    sum[i][j] = ((sum[i][j] + temp[i][k] * temp[k][j]) % mod + mod) % mod;
                }
            }
        }

        n>>=1;
    }
}

int main(int argc, char** argv) {
    //read;
    LL A,B,n,m,c1,c0;
    while(scanf(LLS LLS LLS LLS,&A,&B,&n,&m) != EOF) {
        a[0][0] = 2 * A;
        a[0][1] = B - A*A;
        a[1][0] = 1;
        a[1][1] = 0;
        c0 = 2;
        c1 = 2 * A;
        solve(n,m);
        printf(LLS"\n",((a[1][0] * c1 + a[1][1] * c0)%m+m)%m);
    }
    return 0;
}



發佈了45 篇原創文章 · 獲贊 6 · 訪問量 3萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章