HDU 4565解題報告

So Easy!

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2436    Accepted Submission(s): 751


Problem Description
  A sequence Sn is defined as:

Where a, b, n, m are positive integers.┌x┐is the ceil of x. For example, ┌3.14┐=4. You are to calculate Sn.
  You, a top coder, say: So easy! 
 

Input
  There are several test cases, each test case in one line contains four positive integers: a, b, n, m. Where 0< a, m < 215, (a-1)2< b < a2, 0 < b, n < 231.The input will finish with the end of file.
 

Output
  For each the case, output an integer Sn.
 

Sample Input
2 3 1 2013 2 3 2 2013 2 2 1 2013
 

Sample Output
4 14 4
 

Source
 

Recommend
zhoujiaqi2010   |   We have carefully selected several similar problems for you:  5177 5176 5175 5174 5173 

             

          

                  

            

           參考代碼:

#include<cstdio>
#include<iostream>
#include<cmath>
#include<cstring>
#include<algorithm>
#include<string>
#include<vector>
#include<map>
#include<set>
#include<stack>
#include<queue>
#include<ctime>
#include<cstdlib>
#include<iomanip>
#include<utility>
#define pb push_back
#define mp make_pair
#define CLR(x) memset(x,0,sizeof(x))
#define _CLR(x) memset(x,-1,sizeof(x))
#define REP(i,n) for(int i=0;i<n;i++)
#define Debug(x) cout<<#x<<"="<<x<<" "<<endl
#define REP(i,l,r) for(int i=l;i<=r;i++)
#define rep(i,l,r) for(int i=l;i<r;i++)
#define RREP(i,l,r) for(int i=l;i>=r;i--)
#define rrep(i,l,r) for(int i=1;i>r;i--)
#define read(x) scanf("%d",&x)
#define put(x) printf("%d\n",x)
#define ll long long
#define lson l,m,rt<<1
#define rson m+1,r,rt<<11
using namespace std;
ll a,b,n,m;
struct mat
{
    ll d[4][4];
}A,B,E;

mat multi(mat a,mat b)
{
    mat ans;
    rep(i,0,2)
    {
        rep(j,0,2)
        {
            ans.d[i][j]=0;
            rep(k,0,2)
              if(a.d[i][k]&&b.d[k][j])
                 ans.d[i][j]+=a.d[i][k]*b.d[k][j];
            ans.d[i][j]%=m;
        }
    }
    return ans;
}

mat quickmulti(mat a,ll n)
{
    if(n==0) return E;
    if(n==1) return a;
    mat ans=E;
    while(n)
    {
        if(n&1)
        {
            n--;
            ans=multi(ans,a);
        } 
        else
        {
            n>>=1;
            a=multi(a,a);
        }
    }
    return ans;
}

int main()
{
   E.d[0][0]=E.d[1][1]=1;
   E.d[0][1]=E.d[1][0]=0;
   while(~scanf("%I64d%I64d%I64d%I64d",&a,&b,&n,&m))
   {
       A.d[0][0]=2*a%m,A.d[0][1]=b-a*a;
       while(A.d[0][1]<0) A.d[0][1]+=m;  //將b-a*a變爲正數
       A.d[1][0]=1,A.d[1][1]=0;
       B.d[0][0]=2*(a*a+b)%m,B.d[1][0]=2*a%m;
       B.d[0][1]=B.d[1][1]=0;
       mat ans=quickmulti(A,n-1);
       ans=multi(ans,B);
       printf("%I64d\n",ans.d[1][0]);
   }
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章