Bomb

Bomb

Description

The counter-terrorists found a time bomb in the dust. But this time the terrorists improve on the time bomb. The number sequence of the time bomb counts from 1 to N. If the current number sequence includes the sub-sequence "49", the power of the blast would add one point. 
Now the counter-terrorist knows the number N. They want to know the final points of the power. Can you help them? 
 

Input

The first line of input consists of an integer T (1 <= T <= 10000), indicating the number of test cases. For each test case, there will be an integer N (1 <= N <= 2^63-1) as the description. 

The input terminates by end of file marker. 
 

Output

For each test case, output an integer indicating the final points of the power.
 

Sample Input

3 1 50 500
 

Sample Output

0 1 15

Hint

From 1 to 500, the numbers that include the sub-sequence "49" are "49","149","249","349","449","490","491","492","493","494","495","496","497","498","499", so the answer is 15.
         
題意:求1到n一共有多少個49
 
一個簡單的數位DP題。
<pre name="code" class="plain">#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
__int64 dp[22][4],n;
int b[22];
//dp[i][0]表示長度爲i,包括49的個數
//dp[i][1]表示長度爲i,開頭爲9的個數
//dp[i][2]表示長度爲i,沒有49
void fun()
{
    int i;
   memset(dp,0,sizeof(dp));
    dp[0][2]=1;
    for(i=1;i<20;i++)
    {
      dp[i][0]=(__int64)dp[i-1][0]*10+dp[i-1][1];//有49=上一位有9的 + 上一位有 49 *10 
      dp[i][1]=dp[i-1][2];//有 9的 =上一位無 49的 
      dp[i][2]=(__int64)dp[i-1][2]*10-dp[i-1][1];//    沒有49的 =上一位無 49*10-上一位有9的         
    } 
}
int main()
{
  int t,i;
  fun();
  while(scanf("%d",&t)!=EOF)
  {
     while(t--)
     {
       scanf("%I64d",&n);
       n++;
       int len=0;
       while(n)   
       {
         b[++len]=n%10;
         n/=10; 
       }  
       b[len+1]=0;     
       bool f=0;
       __int64 ans=0;
       for(i=len;i>0;i--)
       {
         ans+=(__int64)b[i]*dp[i-1][0];
         if(f) ans+=(__int64)dp[i-1][2]*b[i];
         if(!f&&b[i]>4)  ans+=dp[i-1][1];
         if(b[i]==9&&b[i+1]==4) f=1;             
       }  
       printf("%I64d\n",ans);    
     }                          
  }
return 0;
}



發佈了90 篇原創文章 · 獲贊 2 · 訪問量 5萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章