HDOJ 1087 Super Jumping! Jumping! Jumping!

Super Jumping! Jumping! Jumping!

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 33884    Accepted Submission(s): 15351


Problem Description
Nowadays, a kind of chess game called “Super Jumping! Jumping! Jumping!” is very popular in HDU. Maybe you are a good boy, and know little about this game, so I introduce it to you now.



The game can be played by two or more than two players. It consists of a chessboard(棋盤)and some chessmen(棋子), and all chessmen are marked by a positive integer or “start” or “end”. The player starts from start-point and must jumps into end-point finally. In the course of jumping, the player will visit the chessmen in the path, but everyone must jumps from one chessman to another absolutely bigger (you can assume start-point is a minimum and end-point is a maximum.). And all players cannot go backwards. One jumping can go from a chessman to next, also can go across many chessmen, and even you can straightly get to end-point from start-point. Of course you get zero point in this situation. A player is a winner if and only if he can get a bigger score according to his jumping solution. Note that your score comes from the sum of value on the chessmen in you jumping path.
Your task is to output the maximum value according to the given chessmen list.
 

Input
Input contains multiple test cases. Each test case is described in a line as follow:
N value_1 value_2 …value_N
It is guarantied that N is not more than 1000 and all value_i are in the range of 32-int.
A test case starting with 0 terminates the input and this test case is not to be processed.
 

Output
For each case, print the maximum according to rules, and one line one case.
 

Sample Input
3 1 3 2 4 1 2 3 4 4 3 3 2 1 0
 

Sample Output
4 10 3
 

Author
lcy
 

這個題其實囉嗦了那麼多就是讓求最大和。

主要是把狀態轉移方程整出來吧,dp實在奇妙……感覺我腦子不太能跟得上=。=


題解:轉移方程是:dp[j]=max(dp[j],dp[i]+a[j])

每一次往後移一個j,就把它之前所有的數再走一遍,看看它之前的序列有多少符合條件。具體過程可以調試,比較容易懂。


#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
#define N 1111
int a[N],dp[N];
int main()
{
	int n;
	int i,j;
	while(scanf("%d",&n),n)
	{
		for(i=0;i<n;i++)
		{
			scanf("%d",&a[i]);
			dp[i]=a[i];	
		}
		for(i=0;i<n;i++)
		{
			for(j=i+1;j<n;j++)
			{
				if(a[j]>a[i])
					dp[j]=max(dp[j],dp[i]+a[j]);
			}
		}
		int maxx=0;
		for(i=0;i<n;i++)
			maxx=max(maxx,dp[i]);
		printf("%d\n",maxx);
	}
	return 0;
}



發佈了247 篇原創文章 · 獲贊 5 · 訪問量 7萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章