XYOJ 1905: Phone List

 Phone List

时间限制: 1 Sec  内存限制: 64 MB

题目描述

Given a list of phone numbers, determine if it is consistent in the sense that no number is the prefix of another. Let's say the phone catalogue listed these numbers:

  • Emergency 911
  • Alice 97 625 999
  • Bob 91 12 54 26

In this case, it's not possible to call Bob, because the central would direct your call to the emergency line as soon as you had dialled the first three digits of Bob's phone number. So this list would not be consistent.

输入

The first line of input gives a single integer, 1 ≤ t ≤ 10, the number of test cases. Each test case starts with n, the number of phone numbers, on a separate line, 1 ≤ n ≤ 100000. Then follows n lines with one unique phone number on each line. A phone number is a sequence of at most ten digits.

输出

For each test case, output "YES" if the list is consistent, or "NO" otherwise.

样例输入

2
3
911
97625999
91125426
5
113
12340
123440
12345
98346

样例输出

NO
YES

解题思路:典型的字典树(容易超内存)

代码如下:

# include<stdio.h>
# include<string.h>
# include<algorithm>
using namespace std;
struct node{
    node * next[10];
    node(){
        memset(next,0,sizeof(next));
    }
}; 
int flag;
struct nod{
    char s[10];
    int len ;
}a[100005];
bool cmp(nod a,nod b)
{
    return a.len>b.len;
}
void insert(char *s,node * & root)        //插入
{  flag=0;       //用来标记是否有重复的
    node *p=root;
    int i,k;
    for(i=0;s[i];i++)
    {
        k=s[i]-'0';
        if(p->next[k]==NULL)
        {
            p->next[k]=new node();
            flag=1;
        }
        p=p->next[k];
    }
}
int main(){
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int n;
        node *root=new node();
        scanf("%d",&n);
        flag=1;
        for(int i=0;i<n;i++)
        {
            scanf("%s",a[i].s);
            a[i].len=strlen(a[i].s);
        }
        sort(a,a+n,cmp);   //将长度排序
        for(int i=0;i<n;i++)
        {
            if(flag)
            insert(a[i].s,root);
            else break;
        }       
        if(flag) printf("YES\n");
        else printf("NO\n");
         
    }
     
    return 0;
}


发布了189 篇原创文章 · 获赞 77 · 访问量 11万+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章