SG專題:HDU1944 S-Nim


Problem Description
Arthur and his sister Caroll have been playing a game called Nim for some time now. Nim is played as follows:


The starting position has a number of heaps, all containing some, not necessarily equal, number of beads.

The players take turns chosing a heap and removing a positive number of beads from it.

The first player not able to make a move, loses.


Arthur and Caroll really enjoyed playing this simple game until they recently learned an easy way to always be able to find the best move:


Xor the number of beads in the heaps in the current position (i.e. if we have 2, 4 and 7 the xor-sum will be 1 as 2 xor 4 xor 7 = 1).

If the xor-sum is 0, too bad, you will lose.

Otherwise, move such that the xor-sum becomes 0. This is always possible.


It is quite easy to convince oneself that this works. Consider these facts:

The player that takes the last bead wins.

After the winning player's last move the xor-sum will be 0.

The xor-sum will change after every move.


Which means that if you make sure that the xor-sum always is 0 when you have made your move, your opponent will never be able to win, and, thus, you will win.

Understandibly it is no fun to play a game when both players know how to play perfectly (ignorance is bliss). Fourtunately, Arthur and Caroll soon came up with a similar game, S-Nim, that seemed to solve this problem. Each player is now only allowed to remove a number of beads in some predefined set S, e.g. if we have S =(2, 5) each player is only allowed to remove 2 or 5 beads. Now it is not always possible to make the xor-sum 0 and, thus, the strategy above is useless. Or is it?

your job is to write a program that determines if a position of S-Nim is a losing or a winning position. A position is a winning position if there is at least one move to a losing position. A position is a losing position if there are no moves to a losing position. This means, as expected, that a position with no legal moves is a losing position.
 

Input
Input consists of a number of test cases.
For each test case: The rst line contains a number k (0 < k <= 100) describing the size of S, followed by k numbers si (0 < si <= 10000) describing S. The second line contains a number m (0 < m <= 100) describing the number of positions to evaluate. The next m lines each contain a number l (0 < l <= 100) describing the number of heaps and l numbers hi (0 <= hi <= 10000) describing the number of beads in the heaps.
The last test case is followed by a 0 on a line of its own.
 

Output
For each position:
If the described position is a winning position print a 'W'.
If the described position is a losing position print an 'L'.
Print a newline after each test case.
 

Sample Input
2 2 5 3 2 5 12 3 2 4 7 4 2 3 7 12 5 1 2 3 4 5 3 2 5 12 3 2 4 7 4 2 3 7 12 0
 

Sample Output
LWW WWL

nim遊戲,注意要打表,記憶化會超時

#include <cstdio>
#include <cstring>
#include <algorithm>

using namespace std;
int f[10010], sg[10010];

void get(int a, int k)
{
    bool mex[10010], res = k;

    memset(f, 0, sizeof(f));
    for (int i = 1; i <= k; ++i)
    {
        memset(mex, 0, sizeof(mex));

        for (int j = 1; j <= a && f[j] <= i; ++j) mex[sg[i - f[j]]] = 1;

        for (int j = 0; j <= k; ++j)
        {
            if (!mex[j])
            {
                res = j;
                break;
            }
        }

        sg[i] = res;
    }
}

int main(void)
{
    int k;
    while (scanf("%d", &k) == 1 && k)
    {
        int T, n, ans, h;
        for (int i = 1; i <= k; ++i) scanf("%d", f + i);
        sort(f + 1, f + k + 1);

        get(k, 10001);
        scanf("%d", &T);
        while (T--)
        {
            scanf("%d", &n);
            ans = 0;
            for (int i = 0; i < n; ++i)
            {
                scanf("%d", &h);
                ans ^= sg[h];
            }
            if (!ans) printf("L");
            else printf("W");
        }
        printf("\n");
    }
    return 0;
}


發佈了11 篇原創文章 · 獲贊 3 · 訪問量 3萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章