文章標題 POJ 1195 :Mobile phones(二維樹狀數組 模板)

Mobile phones

Suppose that the fourth generation mobile phone base stations in the Tampere area operate as follows. The area is divided into squares. The squares form an S * S matrix with the rows and columns numbered from 0 to S-1. Each square contains a base station. The number of active mobile phones inside a square can change because a phone is moved from a square to another or a phone is switched on or off. At times, each base station reports the change in the number of active phones to the main base station along with the row and the column of the matrix.

Write a program, which receives these reports and answers queries about the current total number of active mobile phones in any rectangle-shaped area.
Input
The input is read from standard input as integers and the answers to the queries are written to standard output as integers. The input is encoded as follows. Each input comes on a separate line, and consists of one instruction integer and a number of parameter integers according to the following table.

The values will always be in range, so there is no need to check them. In particular, if A is negative, it can be assumed that it will not reduce the square value below zero. The indexing starts at 0, e.g. for a table of size 4 * 4, we have 0 <= X <= 3 and 0 <= Y <= 3.

Table size: 1 * 1 <= S * S <= 1024 * 1024
Cell value V at any time: 0 <= V <= 32767
Update amount: -32768 <= A <= 32767
No of instructions in input: 3 <= U <= 60002
Maximum number of phones in the whole table: M= 2^30
Output
Your program should not answer anything to lines with an instruction other than 2. If the instruction is 2, then your program is expected to answer the query by writing the answer as a single line containing a single integer to standard output.
Sample Input
0 4
1 1 2 3
2 0 0 2 2
1 1 1 2
1 1 2 -1
2 1 1 2 3
3
Sample Output
3
4

題意:有四個操作,
0 S 表示有S*S的矩陣
1 x y a 表示在x,y這個位置加上a
2 L B R T表示求矩形的和,矩形右上角爲R,T, 左下角爲L,B
分析:用二維樹狀數組來做
代碼:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <queue>
#include <set>
#include <map>
#include <algorithm>
#include <math.h>
#include <vector>
using namespace std;
typedef long long ll;

const int mod=1e9+7;
const int maxn=1500+10;
int S;
int op;
int x,y,a;
int l,b,r,t;

int tree[maxn][maxn];

int lowbit(int x){
    return x&(-x);
}

int add(int x,int y,int val){//x,y>=1
    for (int i=x; i<=S; i+=lowbit(i)){
        for (int j=y; j<=S ;j+=lowbit(j)){
            tree[i][j]+=val;
        }
    }
}

int sum(int x,int y){
    int ans=0;
    for (int i=x; i>0 ;i-=lowbit(i)){
        for (int j=y; j>0 ;j-=lowbit(j)){
            ans+=tree[i][j];
        }
    }
    return ans;
}

int main()
{
    while (1){
        scanf ("%d",&op);
        if (op==3)break;
        if (op==0){
            scanf ("%d",&S);
            memset (tree,0,sizeof (tree));
        }
        else if (op==1){
            scanf ("%d%d%d",&x,&y,&a);
            x++,y++;
            add(x,y,a);
        }else if (op==2){
            scanf ("%d%d%d%d",&l,&b,&r,&t);
            r++,t++;
            int ans=sum(r,t)+sum(l,b)-sum(l,t)-sum(r,b);
            printf ("%d\n",ans);
        }
    }
    return 0;
}
發佈了191 篇原創文章 · 獲贊 1 · 訪問量 4萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章