POJ2560Freckles

易水人去,明月如霜。

Description

In an episode of the Dick Van Dyke show, little Richie connects the freckles on his Dad's back to form a picture of the Liberty Bell. Alas, one of the freckles turns out to be a scar, so his Ripley's engagement falls through.
Consider Dick's back to be a plane with freckles at various (x,y) locations. Your job is to tell Richie how to connect the dots so as to minimize the amount of ink used. Richie connects the dots by drawing straight lines between pairs, possibly lifting the pen between lines. When Richie is done there must be a sequence of connected lines from any freckle to any other freckle.

Input

The first line contains 0 < n <= 100, the number of freckles on Dick's back. For each freckle, a line follows; each following line contains two real numbers indicating the (x,y) coordinates of the freckle.

Output

Your program prints a single real number to two decimal places: the minimum total length of ink lines that can connect all the freckles.

Sample Input

3
1.0 1.0
2.0 2.0
2.0 4.0

Sample Output

3.41

題意 :給出N個點,把N個點連起來的最小距離


思路:最小生成樹


代碼;

#include <cstdio>
#include <iostream>
#include <cstring>
#include <algorithm>
#include <queue>
#include <cmath>
using namespace std;
struct node {
 double x,y;
}a[105];
struct edge {
 int x,y;
 double dis;
}e[1000005];
bool cmp(const edge &a,const edge &b)
{
    return a.dis<b.dis;
}
int fa[105];
int n;
double getdis(node a,node b)
{
    return sqrt((a.x-b.x)*(a.x-b.x)+(a.y-b.y)*(a.y-b.y));
}
int getfa(int x)
{
    if(x==fa[x])
        return fa[x];
    else return fa[x]=getfa(fa[x]);
}
int main()
{
scanf("%d",&n);
int cnt=1;
for(int i=1;i<=n;i++)
{
    scanf("%lf%lf",&a[i].x,&a[i].y);
    fa[i]=i;
    for(int j=1;j<i;j++)
    {
        e[cnt].x=i,e[cnt].y=j;
        e[cnt++].dis=getdis(a[i],a[j]);
    }
}
sort(e+1,e+1+cnt,cmp);
double ans=0;
for(int i=1;i<cnt;i++)
{
 int r1=getfa(e[i].x);
 int r2=getfa(e[i].y);
 if(r1!=r2)
 {
     ans=ans+e[i].dis;
     fa[r1]=r2;
 }
}
printf("%.2f",ans);
 return 0;
}


發佈了105 篇原創文章 · 獲贊 10 · 訪問量 3萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章