POJ2531Network Saboteur

易水人去,明月如霜。

Language:
Network Saboteur
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 12905   Accepted: 6201

Description

A university network is composed of N computers. System administrators gathered information on the traffic between nodes, and carefully divided the network into two subnetworks in order to minimize traffic between parts.
A disgruntled computer science student Vasya, after being expelled from the university, decided to have his revenge. He hacked into the university network and decided to reassign computers to maximize the traffic between two subnetworks.
Unfortunately, he found that calculating such worst subdivision is one of those problems he, being a student, failed to solve. So he asks you, a more successful CS student, to help him.
The traffic data are given in the form of matrix C, where Cij is the amount of data sent between ith and jth nodes (Cij = Cji, Cii = 0). The goal is to divide the network nodes into the two disjointed subsets A and B so as to maximize the sum ∑Cij (i∈A,j∈B).

Input

The first line of input contains a number of nodes N (2 <= N <= 20). The following N lines, containing N space-separated integers each, represent the traffic matrix C (0 <= Cij <= 10000).
Output file must contain a single integer -- the maximum traffic between the subnetworks.

Output

Output must contain a single integer -- the maximum traffic between the subnetworks.

Sample Input

3
0 50 30
50 0 40
30 40 0

Sample Output

90

Source

Northeastern Europe 2002, Far-Eastern Subregion

最大割。

代碼:

#include <cstdio>
#include <iostream>
#include <cstring>
#include <algorithm>
#include <queue>
using namespace std;
int map[25][25],in[25];
int n;
int ans;
void dfs(int id,int sum)
{
  in[id]=true;
  int tem=sum;
  for(int i=1;i<=n;i++)
  {
      if(in[i])
        tem-=map[id][i];
      else tem+=map[id][i];
  }
  if(tem>ans)
  {
      ans=tem;
  }
  if(tem>sum)
  {
 for (int i = id + 1; i <= n; i++){
            dfs(i, tem);
        }
  }
  in[id]=false ;
}
int main()
{
scanf("%d",&n);
for(int i=1;i<=n;i++)
{
    for(int j=1;j<=n;j++)
    {
        scanf("%d",&map[i][j]);
    }
}
dfs(1,0);
printf("%d",ans);
 return 0;
}


發佈了105 篇原創文章 · 獲贊 10 · 訪問量 3萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章