POJ 1157 LITTLE SHOP OF FLOWERS【基礎DP】

LITTLE SHOP OF FLOWERS
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 21366   Accepted: 9876

Description

You want to arrange the window of your flower shop in a most pleasant way. You have F bunches of flowers, each being of a different kind, and at least as many vases ordered in a row. The vases are glued onto the shelf and are numbered consecutively 1 through V, where V is the number of vases, from left to right so that the vase 1 is the leftmost, and the vase V is the rightmost vase. The bunches are moveable and are uniquely identified by integers between 1 and F. These id-numbers have a significance: They determine the required order of appearance of the flower bunches in the row of vases so that the bunch i must be in a vase to the left of the vase containing bunch j whenever i < j. Suppose, for example, you have bunch of azaleas (id-number=1), a bunch of begonias (id-number=2) and a bunch of carnations (id-number=3). Now, all the bunches must be put into the vases keeping their id-numbers in order. The bunch of azaleas must be in a vase to the left of begonias, and the bunch of begonias must be in a vase to the left of carnations. If there are more vases than bunches of flowers then the excess will be left empty. A vase can hold only one bunch of flowers. 

Each vase has a distinct characteristic (just like flowers do). Hence, putting a bunch of flowers in a vase results in a certain aesthetic value, expressed by an integer. The aesthetic values are presented in a table as shown below. Leaving a vase empty has an aesthetic value of 0. 
 

V A S E S

1

2

3

4

5

Bunches

1 (azaleas)

7 23 -5 -24 16

2 (begonias)

5 21 -4 10 23

3 (carnations)

-21

5 -4 -20 20

According to the table, azaleas, for example, would look great in vase 2, but they would look awful in vase 4. 

To achieve the most pleasant effect you have to maximize the sum of aesthetic values for the arrangement while keeping the required ordering of the flowers. If more than one arrangement has the maximal sum value, any one of them will be acceptable. You have to produce exactly one arrangement. 

Input

  • The first line contains two numbers: FV.
  • The following F lines: Each of these lines contains V integers, so that Aij is given as the jth number on the (i+1)st line of the input file.


  • 1 <= F <= 100 where F is the number of the bunches of flowers. The bunches are numbered 1 through F. 
  • F <= V <= 100 where V is the number of vases. 
  • -50 <= Aij <= 50 where Aij is the aesthetic value obtained by putting the flower bunch i into the vase j.

Output

The first line will contain the sum of aesthetic values for your arrangement.

Sample Input

3 5
7 23 -5 -24 16
5 21 -4 10 23
-21 5 -4 -20 20

Sample Output

53

Source


原題鏈接:http://poj.org/problem?id=1157

題意:給出f朵花,v個花瓶,要把花都插到花瓶裏去,而且花的順序不能改變,編號小的在左邊,每朵花放到花瓶裏都會有一定的價值,問如何放才能產生最大的價值

我們設dp[i][j]表示處理到第i朵花,然後把第i朵花放到第j個花瓶裏時所能獲得的最大價值;
顯然 dp[i][j]  = max(dp[i - 1][k]) + val[i][j],其中k< j  val[i][j]表示把第i朵花放到第j個花瓶裏產生的價值

本題dp狀態:


  i=0 i=1 i=2 i=3 i=4 i=5
j=0 0 0 0 0 0 0
j=1 0 7 23 -5 -24 16
j=2 0 -INF 28 19 33 46
j=3    0 -INF -INF -INF 24  8


AC代碼:

/**
  * 行有餘力,則來刷題!
  * 博客鏈接:http://blog.csdn.net/hurmishine
  *
*/
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int maxn=100+5;
const int INF=0x3f3f3f3f;
int a[maxn][maxn];
int dp[maxn][maxn];
int n,m;
int main()
{
    //freopen("C:\\Documents and Settings\\Administrator\\桌面\\data.txt","r",stdin);
    while(cin>>n>>m)
    {
        //memset(dp,-INF,sizeof(dp));
        for(int i=1; i<=n; i++)
        {
            for(int j=1; j<=m; j++)
                cin>>a[i][j],dp[i][j]=-INF;
        }
        for(int i=0; i<=m; i++)
            dp[0][i]=0;

        dp[1][1]=a[1][1];

        for(int i=1; i<=n; i++)
        {
            for(int j=i; j<=m; j++)//j從i開始,小優化
            {
                for(int k=1; k<j; k++)
                {
                    dp[i][j]=max(dp[i][j],dp[i-1][k]+a[i][j]);
                }
            }
        }
        int ans=-INF;
        /**
        for(int i=0;i<=n;i++)
        {
            for(int j=0;j<=m;j++)
                cout<<dp[i][j]<<"\t";
            cout<<endl;
        }
        */
        for(int i=1; i<=m; i++)
        {
            ans=max(ans,dp[n][i]);
        }
        cout<<ans<<endl;

    }
    return 0;
}

參考博客:http://blog.csdn.net/z309241990/article/details/9268679

http://blog.csdn.net/guard_mine/article/details/40892949

http://blog.csdn.net/wangjian8006/article/details/8964060

http://blog.csdn.net/r1986799047/article/details/48506687


發佈了374 篇原創文章 · 獲贊 211 · 訪問量 70萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章