Let the Balloon Rise


Problem Description
Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges' favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.

This year, they decide to leave this lovely job to you.
 

Input
Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.

A test case with N = 0 terminates the input and this test case is not to be processed.
 

Output
For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.
 

Sample Input
5 green red blue red red 3 pink orange pink 0
 

Sample Output
red pink
 
#include <iostream>
#include <cstring>
//#include <cstdio>

using namespace std;

int main( )
{
    //freopen("in.txt", "r", stdin);
    int n, b[1000]={0};
    char a[1000][16];
    while(cin >> n && n)
    {
        cin >> a[0];
        for(int i = 1; i < n; i++)
        {
            cin >> a[i];
            for(int j = 0; j < i-1; j++)
                if(strcmp(a[i], a[j]) == 0)     b[i]+=1;
        }
        int max_color = b[0], num = 0;
        for(int i = 1; i < n; i++)
        {
            if(b[i] > max_color)   {max_color = b[i];   num = i;}
        }
        cout << a[num] << endl;

    }
    return 0;
}



發佈了46 篇原創文章 · 獲贊 8 · 訪問量 4萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章