hdoj 2134 Cuts the cake

                                  Cuts the cake

                               Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
                                                            Total Submission(s): 2541    Accepted Submission(s): 1616


Problem Description
Ice cream took a bronze medal in the Beijing match. Liu sir is very very happy. So he buys a cake for them. kiki is a child who likes eating, so the task of cuting cake was given to kiki. kiki is also a mischievous child. She wants to cut the cake in a different way. This is introduced in the figure below.

But there is a difficult problem.which is how to make each preson get equally many cake. kiki is not good at match, so she wants you help her solve this problem.
 

Input
Input contains multiple test cases. Each line is a case. Each case contains only one integer R which is the radius. The input is terminated with a R of 0.
 

Output
For each test case, you should printf two numbers r2 and r1 in a line, accurate up to 3 decimal places, separate them by one space.
 

Sample Input
10 15 5 25 0
 

Sample Output
5.774 8.165 8.660 12.247 2.887 4.082 14.434 20.412
 

AC CODE:  
include<stdio.h>
#include<math.h>
//#define pi 3.1415926
int main()
{
    double r;        //如果r爲int型,計算結果會誤差很大
    double r1,r2;
    while(~scanf("%lf",&r),r)
    {
        r1=sqrt(r/3*r);
        r2=sqrt(2*r/3*r);
        printf("%.3lf %.3lf\n",r1,r2);
    }
    return 0;
}

發佈了67 篇原創文章 · 獲贊 0 · 訪問量 2萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章