POJ Ants

Ants
Time Limit: 1000MS      Memory Limit: 30000K
Total Submissions: 14970        Accepted: 6504
Description

An army of ants walk on a horizontal pole of length l cm, each with a constant speed of 1 cm/s. When a walking ant reaches an end of the pole, it immediatelly falls off it. When two ants meet they turn back and start walking in opposite directions. We know the original positions of ants on the pole, unfortunately, we do not know the directions in which the ants are walking. Your task is to compute the earliest and the latest possible times needed for all ants to fall off the pole.
Input

The first line of input contains one integer giving the number of cases that follow. The data for each case start with two integer numbers: the length of the pole (in cm) and n, the number of ants residing on the pole. These two numbers are followed by n integers giving the position of each ant on the pole as the distance measured from the left end of the pole, in no particular order. All input integers are not bigger than 1000000 and they are separated by whitespace.
Output

For each case of input, output two numbers separated by a single space. The first number is the earliest possible time when all ants fall off the pole (if the directions of their walks are chosen appropriately) and the second number is the latest possible such time. 
Sample Input

2
10 3
2 6 7
214 7
11 12 7 13 176 23 191
Sample Output

4 8
38 207
Source

Waterloo local 2004.09.19

一道好的思維題我們只要把每個螞蟻的碰撞看成每個螞蟻交換位置就好了
最小的當然是每個螞蟻都走到離自己最近的那個邊
最大的就是每個螞蟻走到離自己最遠的邊了找到兩個裏邊的最大值就好了

#include <cstdio>
#include <iostream>
#include <cstring>
#include <algorithm>
#include <queue>
#include <stack>
#include <cmath>
using namespace std;
const int MAXN=1e6+10;
int a;
int main(){
    int T;  scanf("%d", &T);
    while(T--){
        int L,n; scanf("%d %d",&L,&n);
        int maxx=0; int minn=0;
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&a);
            minn=max(minn,min(a,L-a));
            maxx=max(maxx,max(a,L-a));
        }
        printf("%d %d\n",minn,maxx);

    }

    return 0;
}
發佈了95 篇原創文章 · 獲贊 0 · 訪問量 2萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章