hdu4786Fibonacci Tree

Fibonacci Tree

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 38    Accepted Submission(s): 21


Problem Description
  Coach Pang is interested in Fibonacci numbers while Uncle Yang wants him to do some research on Spanning Tree. So Coach Pang decides to solve the following problem:
  Consider a bidirectional graph G with N vertices and M edges. All edges are painted into either white or black. Can we find a Spanning Tree with some positive Fibonacci number of white edges?
(Fibonacci number is defined as 1, 2, 3, 5, 8, ... )
 

Input
  The first line of the input contains an integer T, the number of test cases.
  For each test case, the first line contains two integers N(1 <= N <= 105) and M(0 <= M <= 105).
  Then M lines follow, each contains three integers u, v (1 <= u,v <= N, u<> v) and c (0 <= c <= 1), indicating an edge between u and v with a color c (1 for white and 0 for black).
 

Output
  For each test case, output a line “Case #x: s”. x is the case number and s is either “Yes” or “No” (without quotes) representing the answer to the problem.
 

Sample Input
2 4 4 1 2 1 2 3 1 3 4 1 1 4 0 5 6 1 2 1 1 3 1 1 4 1 1 5 1 3 5 1 4 2 1
 

Sample Output
Case #1: Yes Case #2: No
 

Source
 

Recommend
We have carefully selected several similar problems for you:  4790 4789 4787 4785 4784 
 

Statistic | Submit | Discuss | Note


題意:給你一些白色跟黑色的邊,問你在這幅圖裏能不能找出一個生成樹且裏面的白邊數量是Fibonacci數列的數

分析:找出白邊最少的生成樹和白邊最多的生成樹的情況,然後看在這之間有沒有Fibonacci數,如果有就是yes啦,沒有就no

爲什麼呢?因爲生成樹是n-1條邊,如果你刪除一條黑邊,必然會孤立一個點,所以你要另一條邊來連接這一個點,如果有白邊就直接連這種情況就是

白邊加一了,如果沒有白邊連出去,那可以知道這個點是沒有任何的白邊連到其他邊。所以最多邊的那副生成樹也不會有這種情況,所以一定會出現中間的生成樹。

還要用到並查集來判斷是否在一個集合。。


#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int f[100005];
int fa[100005];
struct node
{
	int x,y;
	int t;
}node[100005];
bool cmp(struct node a,struct node b)
{
	return a.t<b.t;
}
void Init()
{
	memset(f,0,sizeof(f));
	int l=1,r=2,var;
	f[1] = f[2] = 1;
	while(l+r<100002)
	{
		f[l+r] = 1;
		var = l;
		l = r;
		r = var+r;
	}
}
int find(int x)
{
	return fa[x]==x?x:(fa[x] = find(fa[x]));
}
int findl(int n,int m)
{
	for(int w=0;w<=n;w++)
		fa[w] = w;
	int ans = 0;
	for(int i=0;i<m;i++)
	{
		int xx = find(node[i].x);
		int yy = find(node[i].y);
		if(xx==yy)
			continue;
		fa[xx] = yy;
        ans+=node[i].t;
	}
	int z = find(1);
	for(int j=2;j<=n;j++)
		if(find(j)!=z)
			return 0;
		
		return ans;		
}
int findr(int n,int m)
{
	for(int w=0;w<=n;w++)
		fa[w] = w;
	int ans = 0;
	for(int i=m-1;i>=0;i--)
	{
		int xx = find(node[i].x);
		int yy = find(node[i].y);
		if(xx==yy)
			continue;
		fa[xx] = yy;
        ans+=node[i].t;
	}
	int z = find(1);
	for(int j=2;j<=n;j++)
		if(find(j)!=z)
			return 0;
		
		return ans;		
}
int main()
{
	int n;
	int N,M;
	Init();
	scanf("%d",&n);
	for(int i=1;i<=n;i++)
	{
		scanf("%d%d",&N,&M);
		if(M==0)
		{
			printf("Case #%d: No\n",i);
			continue;
		}
		
		for(int j=0;j<M;j++)
		{
			scanf("%d%d%d",&node[j].x,&node[j].y,&node[j].t);
		}
		
		sort(node,node+M,cmp);
		int l = findl(N,M);
		int r = findr(N,M);
		int FF = 0;
		for(int c=l;c<=r;c++)
			if(f[c]==1)
			{
				FF = 1;
				break;
			}
			if(FF)
				printf("Case #%d: Yes\n",i);
			else
				printf("Case #%d: No\n",i);
	}
	return 0;
}



發佈了58 篇原創文章 · 獲贊 89 · 訪問量 6萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章