poj 1426 Find The Multiple(dfs)

Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal digits.

Input
The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.

Output
For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.

Sample Input

2
6
19
0

Sample Output

10
100100100100100100
111111111111111111

題意:
有一個整數n,讓你找一個適當的m(m只包含0和1且位數不超過100位)的整數
題解:
喵喵喵~這題真是有夠坑的,,,我還以爲要用到Java大數,,,100位,,,這道題總共有兩條搜索路徑,x*10或x*10+1。注意long long的範圍,-(10^19)~(10^20),所以深搜次數不能超過19次,不然會崩掉。這是很重要的一點,也是解題的關鍵點!以後我一定要記住深搜次數這個問題。。。

#include<cstdio>
#include<iostream>
using namespace std;

typedef long long ll;
bool vis;

void dfs(ll m, int n, int step){
    if(vis)
        return ;
    if(step == 19)
        return ;
    if(m % n == 0){
        printf("%lld\n", m);
        vis = 1;
        return ;
    }
    dfs(m*10, n, step+1);
    dfs(m*10+1, n, step+1);
}

int main(){
    int n;
    while(scanf("%d", &n), n){
        vis = 0;
        dfs(1, n, 0);
    }
    return 0;
}
發佈了196 篇原創文章 · 獲贊 316 · 訪問量 200萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章