hdu 3032 Nim or not Nim?(博弈 SG)

Nim is a two-player mathematic game of strategy in which players take turns removing objects from distinct heaps. On each turn, a player must remove at least one object, and may remove any number of objects provided they all come from the same heap.

Nim is usually played as a misere game, in which the player to take the last object loses. Nim can also be played as a normal play game, which means that the person who makes the last move (i.e., who takes the last object) wins. This is called normal play because most games follow this convention, even though Nim usually does not.

Alice and Bob is tired of playing Nim under the standard rule, so they make a difference by also allowing the player to separate one of the heaps into two smaller ones. That is, each turn the player may either remove any number of objects from a heap or separate a heap into two smaller ones, and the one who takes the last object wins.

Input
Input contains multiple test cases. The first line is an integer 1 ≤ T ≤ 100, the number of test cases. Each case begins with an integer N, indicating the number of the heaps, the next line contains N integers s[0], s[1], …., s[N-1], representing heaps with s[0], s[1], …, s[N-1] objects respectively.(1 ≤ N ≤ 10^6, 1 ≤ S[i] ≤ 2^31 - 1)

Output
For each test case, output a line which contains either “Alice” or “Bob”, which is the winner of this game. Alice will play first. You may asume they never make mistakes.
Sample Input

2
3
2 2 3
2
3 3

Sample Output

Alice
Bob

題解:
題意:有n堆石子,兩個人輪流選一個石堆拿若干石頭或將其中一堆分成兩小堆,誰先取完誰贏

咳咳,現在輪到重頭戲,sg打表找規律嘍~
(不知道sg函數的轉https://blog.csdn.net/ling_wang/article/details/80644805
sg[0]=0

sg[1] = mex{sg[0] } = 1

sg[2] = mex{sg[0], sg[1], sg[1, 1] } = mex{0, 1, sg[1]^sg[1]} = 2;

sg[3] = mex{sg[0], sg[1], sg[2], sg[1, 2]} = mex{0, 1, 2, 1^2} = mex{0, 1, 2, 3} = 4;

sg[4] = mex{sg[0], sg[1], sg[2], sg[3], sg[1, 3], sg[2, 2]} = mex{0, 1, 2, 4, 2, 0} = 3;

sg[5] = mex{sg[0], sg[1], sg[2], sg[3], sg[4], sg[1, 4], sg[2, 3]} = mex{0, 1, 2, 4, 3, 2, 1} = 5;
.
.
.

so,我們可以發現
sg[4*k+1]=4*k+1, sg[4*k+2]=4*k+2, sg[4*k+3]=4*k+4, sg[4*k+4]=4*k+3

然後就可以寫代碼了~

#include<bits/stdc++.h>
using namespace std;

typedef long long ll;
const int N = 1e6 + 10;

int getsg(int x){
    if(x == 0)      return x;//因爲0%任何數都爲0,將該情況單列
    if(x%4 == 3)    return x+1;
    if(x%4 == 0)    return x-1;
    return x;
}


int main(){
    int T, n;
    ll ans, t;
    scanf("%d", &T);
    while(T--){
        ans = 0;
        scanf("%d", &n);
        while(n--){
            scanf("%lld", &t);
            ans ^= getsg(t);
        }
        if(ans)
            printf("Alice\n");
        else
            printf("Bob\n");
    }
    return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章