poj 3984 迷宮問題(bfs+路徑記錄)

定義一個二維數組:


int maze[5][5] = {

    0, 1, 0, 0, 0,

    0, 1, 0, 1, 0,

    0, 0, 0, 0, 0,

    0, 1, 1, 1, 0,

    0, 0, 0, 1, 0,

};


它表示一個迷宮,其中的1表示牆壁,0表示可以走的路,只能橫着走或豎着走,不能斜着走,要求編程序找出從左上角到右下角的最短路線。 

Input
一個5 × 5的二維數組,表示一個迷宮。數據保證有唯一解。
Output
左上角到右下角的最短路徑,格式如樣例所示。
Sample Input

0 1 0 0 0
0 1 0 1 0
0 0 0 0 0
0 1 1 1 0
0 0 0 1 0

Sample Output

(0, 0)
(1, 0)
(2, 0)
(2, 1)
(2, 2)
(2, 3)
(2, 4)
(3, 4)
(4, 4)
#include<cstdio>
#include<cstring>
#include<queue>
#include<iostream>
using namespace std;

int vis[6][6];
int mp[6][6];
int d[4][2] = {{0, 1}, {0, -1}, {1, 0}, {-1, 0}};

struct node{
    int x, y;
};

node pre[6][6];

void print(){//逆序輸出
    node lu[100];
    int i = 0;
    lu[i].x = lu[i].y = 4;
    //printf("(%d, %d)\n", lu[i].x, lu[i].y);
    for(;;){
        if(lu[i].x == 0 && lu[i].y == 0)
            break;
        else{
            lu[i+1] = pre[lu[i].x][lu[i].y];
        }
        i++;
    }
   // cout << "i = " << i << endl;
    while(i >= 0){
        printf("(%d, %d)\n", lu[i].x, lu[i].y);
        i--;
    }
}

void bfs(){
    queue<node> q;
    node a, ne;
    vis[0][0] = 1;
    q.push(node{0, 0});
    while(!q.empty()){
        a = q.front();
        q.pop();
        if(a.x == 4 && a.y == 4){
            print();
            return ;
        }
        for(int i = 0; i < 4; i++){
            ne.x = a.x + d[i][0];
            ne.y = a.y + d[i][1];
            if(!vis[ne.x][ne.y] && ne.x >=0 && ne.y >= 0 && ne.x < 5 && ne.y < 5 && mp[ne.x][ne.y] != 1){
                q.push(ne);
                //cout << "ne.x = " << ne.x << " ne.y = " << ne.y << endl;
                pre[ne.x][ne.y] = a;
                //cout << "pre.x = " << pre[ne.x][ne.y].x << " pre.y = " << pre[ne.x][ne.y].y << endl;
                vis[ne.x][ne.y] = 1;
            }
        }
    }
}

int main(){
    for(int i = 0; i < 5; i++){
        for(int j = 0; j < 5; j++){
            scanf("%d", &mp[i][j]);
        }
    }
    memset(vis, 0, sizeof(vis));
    bfs();
    return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章