HDU 3714 - Error Curves (三分查找)

Description

Josephina is a clever girl and addicted to Machine Learning recently. She
pays much attention to a method called Linear Discriminant Analysis, which
has many interesting properties.
In order to test the algorithm’s efficiency, she collects many datasets.
What’s more, each data is divided into two parts: training data and test
data. She gets the parameters of the model on training data and test the
model on test data. To her surprise, she finds each dataset’s test error curve is just a parabolic curve. A parabolic curve corresponds to a quadratic function. In mathematics, a quadratic function is a polynomial function of the form f(x) = ax2 + bx + c. The quadratic will degrade to linear function if a = 0.


It’s very easy to calculate the minimal error if there is only one test error curve. However, there are several datasets, which means Josephina will obtain many parabolic curves. Josephina wants to get the tuned parameters that make the best performance on all datasets. So she should take all error curves into account, i.e., she has to deal with many quadric functions and make a new error definition to represent the total error. Now, she focuses on the following new function’s minimum which related to multiple quadric functions. The new function F(x) is defined as follows: F(x) = max(Si(x)), i = 1…n. The domain of x is 0,1000. Si(x) is a quadric function. Josephina wonders the minimum of F(x). Unfortunately, it’s too hard for her to solve this problem. As a super programmer, can you help her?

Input

The input contains multiple test cases. The first line is the number of cases T (T < 100). Each case begins with a number n (n ≤ 10000). Following n lines, each line contains three integers a (0 ≤ a ≤ 100), b (|b| ≤ 5000), c (|c| ≤ 5000), which mean the corresponding coefficients of a quadratic function.

Output

For each test case, output the answer in a line. Round to 4 digits after the decimal point.

Sample Input

2
1
2 0 0
2
2 0 0
2 -4 2

Sample Output

0.0000
0.5000


Solution
題目大意:給定n個函數 f(x)=ax2+bx+c,F(x)=max(Si(x)),i=1...n,F(x) 結果保留四位小數。F(x)f(x)[0,1000]F(x) a>0開口向上,直接三分即可。


Code

#include <stdio.h>
#include <algorithm>
#include <iostream>
using namespace std;
#define eps 1e-9
const int N = 10010;
int a[N], b[N], c[N];
int n;


double fx(double x)
{
    double ans = a[0] * x*x + b[0] * x + c[0];
    for (int i = 1; i < n; i++)
        ans = max(ans, a[i] * x*x + b[i] * x + c[i]);
        return ans;
}


int main( )
{
    int T;
    scanf("%d", &T);
    while (T--)
    {
        scanf("%d", &n);
        for (int i = 0; i < n; i++)
            scanf("%d%d%d", &a[i], &b[i], &c[i]);
        double l = 0, r = 1000;
        while (r-l>eps)
        {
            double lmid = l + (r - l) / 3;
            double rmid = r - (r - l) / 3;
            if (fx(lmid)<fx(rmid)) r = rmid;
            else l = lmid;

        }
        printf("%.4lf\n", fx(l));

    }
    return 0;
}
發佈了77 篇原創文章 · 獲贊 47 · 訪問量 20萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章