PAT (Advanced Level) 1082. Read Number in Chinese (25) 數字轉漢字大寫

Given an integer with no more than 9 digits, you are supposed to read it in the traditional Chinese way. Output "Fu" first if it is negative. For example, -123456789 is read as "Fu yi Yi er Qian san Bai si Shi wu Wan liu Qian qi Bai ba Shi jiu". Note: zero ("ling") must be handled correctly according to the Chinese tradition. For example, 100800 is "yi Shi Wan ling ba Bai".

Input Specification:

Each input file contains one test case, which gives an integer with no more than 9 digits.

Output Specification:

For each test case, print in a line the Chinese way of reading the number. The characters are separated by a space and there must be no extra space at the end of the line.

Sample Input 1:
-123456789
Sample Output 1:
Fu yi Yi er Qian san Bai si Shi wu Wan liu Qian qi Bai ba Shi jiu
Sample Input 2:
100800
Sample Output 2:
yi Shi Wan ling ba Bai
分成高1位、中4位、低4位進行處理。注意中間有多個0重複只輸出一個"ling",末尾和前綴都不能輸出"ling"。
/*2015.7.30cyq*/
#include <iostream>
#include <string>
#include <vector>
using namespace std;

string num[11]={"ling","yi","er","san","si","wu","liu","qi","ba","jiu"};
string danwei[4]={"","Shi","Bai","Qian"};
int main(){
	int N;
	cin>>N;
	if(N==0){
		cout<<"ling";
		return 0;
	}
	vector<string> result;
	if(N<0){
		result.push_back("Fu");
		N=-N;
	}
	int high=N/100000000;
	int mid=N/10000%10000;
	int low=N%10000;
	int tmp=mid;

	if(high>0){
		result.push_back(num[high]);
		result.push_back("Yi");
	}
	if(mid>0){//中間4位
		vector<int> tmp(4);
		tmp[0]=mid%10;
		tmp[1]=mid%100/10;
		tmp[2]=mid%1000/100;
		tmp[3]=mid/1000;
		for(int i=3;i>=1;i--){
			if(tmp[i]>0){
				result.push_back(num[tmp[i]]);
				result.push_back(danwei[i]);
			}else{//tmp[i]==0
				if(!result.empty()){//避免0前綴或0重複
					if(result.back()!="ling"&&result.back()!="Fu")
						result.push_back("ling");
				}
			}
		}
		if(tmp[0]>0)
			result.push_back(num[tmp[0]]);//最低位無單位
		while(result.back()=="ling")//去掉末尾的0
			result.erase(result.end()-1);
		result.push_back("Wan");
	}
	if(low>0){//低4位
		if(high>0&&mid==0)
			result.push_back("ling");
		vector<int> tmp(4);
		tmp[0]=low%10;
		tmp[1]=low%100/10;
		tmp[2]=low%1000/100;
		tmp[3]=low/1000;
		for(int i=3;i>=1;i--){
			if(tmp[i]>0){
				result.push_back(num[tmp[i]]);
				result.push_back(danwei[i]);
			}else{//tmp[i]==0
				if(!result.empty()){//避免0前綴或0重複
					if(result.back()!="ling"&&result.back()!="Fu")
						result.push_back("ling");
				}
			}
		}
		if(tmp[0]>0)
			result.push_back(num[tmp[0]]);//最低位無單位
		while(result.back()=="ling")//去掉末尾的0
			result.erase(result.end()-1);
	}

	cout<<result[0];
	for(auto it=result.begin()+1;it!=result.end();it++)
		cout<<" "<<*it;
	return 0;
}

發佈了142 篇原創文章 · 獲贊 4 · 訪問量 9萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章