PAT (Advanced level) 1077. Kuchiguse (20) 最長共同後綴

The Japanese language is notorious for its sentence ending particles. Personal preference of such particles can be considered as a reflection of the speaker's personality. Such a preference is called "Kuchiguse" and is often exaggerated artistically in Anime and Manga. For example, the artificial sentence ending particle "nyan~" is often used as a stereotype for characters with a cat-like personality:

Itai nyan~ (It hurts, nyan~) Ninjin wa iyada nyan~ (I hate carrots, nyan~)

Now given a few lines spoken by the same character, can you find her Kuchiguse?

Input Specification:

Each input file contains one test case. For each case, the first line is an integer N (2<=N<=100). Following are N file lines of 0~256 (inclusive) characters in length, each representing a character's spoken line. The spoken lines are case sensitive.

Output Specification:

For each test case, print in one line the kuchiguse of the character, i.e., the longest common suffix of all N lines. If there is no such suffix, write "nai".

Sample Input 1:
3
Itai nyan~
Ninjin wa iyadanyan~
uhhh nyan~
Sample Output 1:
nyan~
Sample Input 2:
3
Itai!
Ninjinnwaiyada T_T
T_T
Sample Output 2:
nai
從後往前遍歷。
/*2015.7.29cyq*/
#include <iostream>
#include <string>
#include <vector>
#include <fstream>
#include <cstring>
using namespace std;

//ifstream fin("case1.txt");
//#define cin fin

int main(){
	int N;
	cin>>N;
	string enter;
	getline(cin,enter);//去掉第一行的回車
	vector<string> svec(N);
	vector<int> len(N);
	for(int i=0;i<N;i++){
		getline(cin,svec[i]);
		len[i]=svec[i].size();
	}
	int count=0;
	bool flag;
	for(int i=1;i<=len[0];i++){
		flag=true;
		for(int j=1;j<N;j++){//第二個string及之後的string
			if(len[j]<i||svec[j][len[j]-i]!=svec[0][len[0]-i]){
				flag=false;
				break;
			}
		}
		if(!flag)
			break;
		count++;
	}
	if(count==0)
		cout<<"nai";
	else
		cout<<svec[0].substr(len[0]-count);
	return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章