PAT (Advanced Level) 1074. Reversing Linked List (25) 翻轉鏈表

Given a constant K and a singly linked list L, you are supposed to reverse the links of every K elements on L. For example, given L being 1→2→3→4→5→6, if K = 3, then you must output 3→2→1→6→5→4; if K = 4, you must output 4→3→2→1→5→6.

Input Specification:

Each input file contains one test case. For each case, the first line contains the address of the first node, a positive N (<= 105) which is the total number of nodes, and a positive K (<=N) which is the length of the sublist to be reversed. The address of a node is a 5-digit nonnegative integer, and NULL is represented by -1.

Then N lines follow, each describes a node in the format:

Address Data Next

where Address is the position of the node, Data is an integer, and Next is the position of the next node.

Output Specification:

For each case, output the resulting ordered linked list. Each node occupies a line, and is printed in the same format as in the input.

Sample Input:
00100 6 4
00000 4 99999
00100 1 12309
68237 6 -1
33218 3 00000
99999 5 68237
12309 2 33218
Sample Output:
00000 4 33218
33218 3 12309
12309 2 00100
00100 1 99999
99999 5 68237
68237 6 -1
這道題的代碼之前寫過了,寫法是將其當成真實的鏈表進行模擬操作PAT 數據結構 02-線性結構1. Reversing Linked List (25),寫起來略繁瑣。

注意到題目給的用例是靜態鏈表,這次我直接將鏈表頭及之後的結點順序壓入數組,每K個進行翻轉,寫起來非常快。
/*2015.7.29cyq*/
#include <iostream>
#include <vector>
#include <fstream>
using namespace std;

//fstream fin("case1.txt");
//#define cin fin

struct LNode{
	int addr;
	int val;
	int next;
};
void reverse(vector<LNode> &res,int begin,int end){
	while(begin<end){
		swap(res[begin],res[end]);
		begin++;
		end--;
	}
}
int main(){
	int head,N,K;
	cin>>head>>N>>K;
	vector<LNode> L(100000);
	int a,b,c;
	for(int i=0;i<N;i++){
		cin>>a>>b>>c;
		L[a].addr=a;
		L[a].val=b;
		L[a].next=c;
	}
	vector<LNode> result;
	int p=head;
	while(p!=-1){
		result.push_back(L[p]);
		p=L[p].next;
	}
	int len=result.size();
	int count=len/K; //翻轉的次數
	for(int i=0;i<count;i++){
		reverse(result,i*K,(i+1)*K-1);
	}
	for(int i=0;i<len-1;i++){
		result[i].next=result[i+1].addr;
		printf("%05d %d %05d\n",result[i].addr,result[i].val,result[i].next);
	}
	result[len-1].next=-1;
	printf("%05d %d %d\n",result[len-1].addr,result[len-1].val,result[len-1].next);
	return 0;
}

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章