PAT (Advanced Level) 1073. Scientific Notation (20) 科學計數法

Scientific notation is the way that scientists easily handle very large numbers or very small numbers. The notation matches the regular expression [+-][1-9]"."[0-9]+E[+-][0-9]+ which means that the integer portion has exactly one digit, there is at least one digit in the fractional portion, and the number and its exponent's signs are always provided even when they are positive.

Now given a real number A in scientific notation, you are supposed to print A in the conventional notation while keeping all the significant figures.

Input Specification:

Each input file contains one test case. For each case, there is one line containing the real number A in scientific notation. The number is no more than 9999 bytes in length and the exponent's absolute value is no more than 9999.

Output Specification:

For each test case, print in one line the input number A in the conventional notation, with all the significant figures kept, including trailing zeros,

Sample Input 1:
+1.23400E-03
Sample Output 1:
0.00123400
Sample Input 2:
-1.2E+10
Sample Output 2:
-12000000000
提取底數有效位的字符串,提取指數並進行分類討論。
/*2015.7.29cyq*/
#include <iostream>
#include <string>
#include <sstream>
using namespace std;

int toInt(string s){
	stringstream ss;
	ss<<s.substr(1);
	int a;
	ss>>a;
	if(s[0]=='-')
		a=-a;
	return a;
}

int main(){
	string s;
	cin>>s;
	int n=s.size();
	int i=0;
	bool flag=true;
	if(s[i]=='+')
		i++;
	else if(s[i]=='-'){
		flag=false;
		i++;
	}
	string base;//有效數字字符串
	while(i<n&&s[i]!='E'){
		if(s[i]!='.'){
			base+=s[i];
		}
		i++;
	}

	i++;//此時i所在位置爲指數的符號'+'或'-'
	int exp=toInt(s.substr(i));	//指數
	int len=base.size();

	if(!flag)
		cout<<"-";
	if(exp<=0){//前面補0和'.'
		string tmp(-exp,'0');
		tmp=tmp+base;
		tmp.insert(1,1,'.');
		cout<<tmp;
	}else if(exp==len-1){
		cout<<base;
	}else if(exp<len-1){//插入'.'
		base.insert(exp+1,1,'.');
		cout<<base;
	}else{//後面補0
		string tmp(exp-(len-1),'0');
		base=base+tmp;
		cout<<base;
	}
	return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章