PAT甲級1108

1108 Finding Average (20 分)

The basic task is simple: given N real numbers, you are supposed to calculate their average. But what makes it complicated is that some of the input numbers might not be legal. A legal input is a real number in [−1000,1000] and is accurate up to no more than 2 decimal places. When you calculate the average, those illegal numbers must not be counted in.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤100). Then N numbers are given in the next line, separated by one space.

Output Specification:

For each illegal input number, print in a line ERROR: X is not a legal number where X is the input. Then finally print in a line the result: The average of K numbers is Y where K is the number of legal inputs and Y is their average, accurate to 2 decimal places. In case the average cannot be calculated, output Undefinedinstead of Y. In case K is only 1, output The average of 1 number is Y instead.

Sample Input 1:

7
5 -3.2 aaa 9999 2.3.4 7.123 2.35

Sample Output 1:

ERROR: aaa is not a legal number
ERROR: 9999 is not a legal number
ERROR: 2.3.4 is not a legal number
ERROR: 7.123 is not a legal number
The average of 3 numbers is 1.38

Sample Input 2:

2
aaa -9999

Sample Output 2:

ERROR: aaa is not a legal number
ERROR: -9999 is not a legal number
The average of 0 numbers is Undefined
#include<bits/stdc++.h>
using namespace std;

double temp;

bool isnum(char str[]){
	temp = 0;
	int size = strlen(str);
	bool point = false;
	int pointindex = 0;
	for(int i = 0; i < size; i++){
		if(str[i] == '-'){
			if(i == 0 )
				continue;
			
		}
		if(str[i] >= '0' && str[i] <= '9'){
			if(!point)
				temp = temp * 10 + str[i] - '0';
			else
				temp += (str[i] - '0') * pow(10, pointindex - i);
		}
		else if(str[i] == '.'){
			if(point)
				return false;
			pointindex = i;
			if(size - 1 - pointindex > 2)
				return false;
			point = true;
		}
		else
			return false;
	}
	if(str[0] == '-')
		temp *= -1;
	if(temp <= 1000 && temp >= -1000)
		return true;
	return false;
}

int main(){
	int n;
	scanf("%d", &n);
	char str[100];
	double sum = 0, num = 0;
	for(int i = 0; i < n; i++){
		scanf("%s", &str);
		if(isnum(str)){
			num++;
			sum += temp;
		}
		else
			printf("ERROR: %s is not a legal number\n", str);
	} 
	if(num == 0)
		printf("The average of %d numbers is Undefined", int(num));
	else if(num == 1)
		printf("The average of %d number is %.2lf", int(num), sum);
	else
		printf("The average of %d numbers is %.2lf", int(num), sum / num);
	return 0;
}

 

發佈了117 篇原創文章 · 獲贊 15 · 訪問量 7278
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章