PAT甲級1043

1043 Is It a Binary Search Tree (25 分)

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node's key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
  • Both the left and right subtrees must also be binary search trees.

If we swap the left and right subtrees of every node, then the resulting tree is called the Mirror Image of a BST.

Now given a sequence of integer keys, you are supposed to tell if it is the preorder traversal sequence of a BST or the mirror image of a BST.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤1000). Then N integer keys are given in the next line. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first print in a line YES if the sequence is the preorder traversal sequence of a BST or the mirror image of a BST, or NO if not. Then if the answer is YES, print in the next line the postorder traversal sequence of that tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input 1:

7
8 6 5 7 10 8 11

Sample Output 1:

YES
5 7 6 8 11 10 8

Sample Input 2:

7
8 10 11 8 6 7 5

Sample Output 2:

YES
11 8 10 7 5 6 8

Sample Input 3:

7
8 6 8 5 10 9 11

Sample Output 3:

NO

先通過二叉排序樹的方法構建二叉樹,然後構造先序,後序,鏡像先序,鏡像後序四個函數,如果輸入的序列符合二叉樹的先序序列或鏡像先序序列的話,就輸出對應的後序序列,反之輸出NO

#include<iostream>
#include<algorithm>
#include<vector>
using namespace std;

struct Node{
	int data;
	Node* lchild;
	Node* rchild;
};

vector<int> chushi, pre, post, mpre, mpost;

void bst(Node* &root, int data){
	if (root == NULL){
		root = new Node;
		root->data = data;
		root->lchild = NULL;
		root->rchild = NULL;
		return;
	}
	if (data < root->data)
		bst(root->lchild, data);
	else
		bst(root->rchild, data);
}

void preorder(Node* root){
	if (root == NULL)
		return;
	pre.push_back(root->data);
	preorder(root->lchild);
	preorder(root->rchild);
}

void postorder(Node* root){
	if (root == NULL)
		return;
	postorder(root->lchild);
	postorder(root->rchild);
	post.push_back(root->data);
}

void mpreorder(Node* root){
	if (root == NULL)
		return;
	mpre.push_back(root->data);
	mpreorder(root->rchild);
	mpreorder(root->lchild);
}

void mpostorder(Node* root){
	if (root == NULL)
		return;
	mpostorder(root->rchild);
	mpostorder(root->lchild);
	mpost.push_back(root->data);
}

int main(){
	int n, data;
	scanf("%d", &n);
	Node* root = NULL;
	for (int i = 0; i < n; i++){
		scanf("%d", &data);
		chushi.push_back(data);
		bst(root, data);
	}
	preorder(root);
	postorder(root);
	mpreorder(root);
	mpostorder(root);
	if (chushi == pre){
		printf("YES\n");
		for (int i = 0; i < n;i++)
		if (i != n - 1)
			printf("%d ", post[i]);
		else
			printf("%d", post[i]);
	}
	else if (chushi == mpre){
		printf("YES\n");
		for (int i = 0; i < n; i++)
		if (i != n - 1)
			printf("%d ", mpost[i]);
		else
			printf("%d", mpost[i]);
	}
	else
		printf("NO");
	return 0;
}

 

發佈了117 篇原創文章 · 獲贊 15 · 訪問量 7297
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章