PAT甲級1107

1107 Social Clusters (30 分)

When register on a social network, you are always asked to specify your hobbies in order to find some potential friends with the same hobbies. A social cluster is a set of people who have some of their hobbies in common. You are supposed to find all the clusters.

Input Specification:

Each input file contains one test case. For each test case, the first line contains a positive integer N (≤1000), the total number of people in a social network. Hence the people are numbered from 1 to N. Then N lines follow, each gives the hobby list of a person in the format:

K​i​​: h​i​​[1] h​i​​[2] ... h​i​​[K​i​​]

where K​i​​ (>0) is the number of hobbies, and h​i​​[j] is the index of the j-th hobby, which is an integer in [1, 1000].

Output Specification:

For each case, print in one line the total number of clusters in the network. Then in the second line, print the numbers of people in the clusters in non-increasing order. The numbers must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

8
3: 2 7 10
1: 4
2: 5 3
1: 4
1: 3
1: 4
4: 6 8 1 5
1: 4

Sample Output:

3
4 3 1
#include<bits/stdc++.h>
using namespace std;

const int Max = 1010;
int root[Max], isroot[Max] = {0}, c[Max] = {0};

int findroot(int x){
	while(x != root[x])
		x = root[x];
	return x;
}

void v(int a, int b){
	int roota = findroot(a);
	int rootb = findroot(b);
	if(roota != rootb)
		root[roota] = rootb;
}

bool cmp(int a, int b){
	return a > b;
}

int main(){
	int n, k, x;
	scanf("%d", &n);
	for(int i = 1; i <= n; i++)
		root[i] = i;
	for(int i = 1; i <= n; i++){
		scanf("%d: ", &k);
		for(int j = 0; j < k; j++){
			scanf("%d", &x);
			if(c[x] == 0)
				c[x] = i;
			v(i, findroot(c[x]));
		}
	}
	for(int i = 1; i <= n; i++)
		isroot[findroot(i)]++;
	int num = 0;
	for(int i = 1; i <= n; i++)
	if(isroot[i] != 0)
		num++;
	printf("%d\n", num);
	sort(isroot + 1, isroot + n + 1, cmp);
	for(int i = 1; i <= num; i++)
	if(i != num)
		printf("%d ", isroot[i]);
	else
		printf("%d", isroot[i]);
	return 0;
}

 

發佈了117 篇原創文章 · 獲贊 15 · 訪問量 7295
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章