PAT甲級1094

1094 The Largest Generation (25 分)

A family hierarchy is usually presented by a pedigree tree where all the nodes on the same level belong to the same generation. Your task is to find the generation with the largest population.

Input Specification:

Each input file contains one test case. Each case starts with two positive integers N (<100) which is the total number of family members in the tree (and hence assume that all the members are numbered from 01 to N), and M (<N) which is the number of family members who have children. Then M lines follow, each contains the information of a family member in the following format:

ID K ID[1] ID[2] ... ID[K]

where ID is a two-digit number representing a family member, K (>0) is the number of his/her children, followed by a sequence of two-digit ID's of his/her children. For the sake of simplicity, let us fix the root ID to be 01. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the largest population number and the level of the corresponding generation. It is assumed that such a generation is unique, and the root level is defined to be 1.

Sample Input:

23 13
21 1 23
01 4 03 02 04 05
03 3 06 07 08
06 2 12 13
13 1 21
08 2 15 16
02 2 09 10
11 2 19 20
17 1 22
05 1 11
07 1 14
09 1 17
10 1 18

Sample Output:

9 4
#include<iostream>
#include<algorithm>
#include<vector>
#include<queue>
using namespace std;

struct Node{
	int deep;
	vector<int> child;
}node[110];

int n, m;
double p, r, temp = 0;

void bfs(int root, int deep){
	node[root].deep = deep;
	queue<int> q;
	q.push(root);
	while (!q.empty()){
		int top = q.front();
		q.pop();
		if (temp < node[top].deep)
			temp = node[top].deep;
		if (node[top].child.size()!=0)
		for (int i = 0; i < node[top].child.size(); i++){
			node[node[top].child[i]].deep = node[top].deep + 1;
			q.push(node[top].child[i]);
		}
	}
}

int main(){
	scanf("%d %d", &n, &m);
	int no, k, x;
	for (int i = 0; i < m; i++){
		scanf("%d %d", &no, &k);
		for (int j = 0; j < k; j++){
			scanf("%d", &x);
			node[no].child.push_back(x);
		}
	}
	bfs(1, 1);
	int deep[110] = { 0 };
	for (int i = 1; i <= n; i++)
		deep[node[i].deep]++;
	int num = 0, d;
	for (int i = 1; i <= temp; i++){
		if (num < deep[i]){
			num = deep[i];
			d = i;
		}
	}
	printf("%d %d", num, d);
}

 

發佈了117 篇原創文章 · 獲贊 15 · 訪問量 7300
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章