hdu2767 Proving Equivalences[強連通分量]

Proving Equivalences

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1792    Accepted Submission(s): 675


Problem Description
Consider the following exercise, found in a generic linear algebra textbook.

Let A be an n × n matrix. Prove that the following statements are equivalent:

1. A is invertible.
2. Ax = b has exactly one solution for every n × 1 matrix b.
3. Ax = b is consistent for every n × 1 matrix b.
4. Ax = 0 has only the trivial solution x = 0. 

The typical way to solve such an exercise is to show a series of implications. For instance, one can proceed by showing that (a) implies (b), that (b) implies (c), that (c) implies (d), and finally that (d) implies (a). These four implications show that the four statements are equivalent.

Another way would be to show that (a) is equivalent to (b) (by proving that (a) implies (b) and that (b) implies (a)), that (b) is equivalent to (c), and that (c) is equivalent to (d). However, this way requires proving six implications, which is clearly a lot more work than just proving four implications!

I have been given some similar tasks, and have already started proving some implications. Now I wonder, how many more implications do I have to prove? Can you help me determine this?
 

Input
On the first line one positive number: the number of testcases, at most 100. After that per testcase:

* One line containing two integers n (1 ≤ n ≤ 20000) and m (0 ≤ m ≤ 50000): the number of statements and the number of implications that have already been proved.
* m lines with two integers s1 and s2 (1 ≤ s1, s2 ≤ n and s1 ≠ s2) each, indicating that it has been proved that statement s1 implies statement s2.
 

Output
Per testcase:

* One line with the minimum number of additional implications that need to be proved in order to prove that all statements are equivalent.
 

Sample Input
2 4 0 3 2 1 2 1 3
 

Sample Output
4 2
 

Source
 

Recommend
lcy

題目大意:

給出一個有向圖,問至少添加多少條邊使圖變成一個強連通分量。

解題思路:

先縮點,然後答案就是入度爲0的點的個數和出度爲0的點的個數中的最大的。但是尤其要注意縮點之後只有一個強連通分量的時候!第一次交的時候就忘了這個了!
#include<cstdio>
#include<cstring>
#include<iostream>
#include<stack>
using namespace std;
pair<int,int>side[50001];
stack<int>q;
int top,node[20001],low[20001],dfn[20001],in[20001],out[20001],t,cnt;
int n,m;
void dfs(int u){
	low[u]=dfn[u]=t++;
	q.push(u);
	int v;
	for(int i=node[u];i!=-1;i=side[i].second){
		v=side[i].first;
		if(!dfn[v])dfs(v);
		if(dfn[v]!=-1)low[u]=min(low[u],low[v]);
	}
	if(low[u]==dfn[u]){
		do{
			v=q.top();q.pop();
			dfn[v]=-1;
			low[v]=cnt;
		}while(v!=u);
		cnt++;
	}
}
void tarjan(){
	memset(dfn,0,sizeof(dfn));
	while(!q.empty())q.pop();
	cnt=0,t=1;
	for(int i=1;i<=n;i++){
		if(!dfn[i])dfs(i);
	}
}
int main(){
	int T;
	scanf("%d",&T);
	while(T--){
		top=0;
		memset(node,-1,sizeof(node));
		memset(in,0,sizeof(in));
		memset(out,0,sizeof(out));
		scanf("%d%d",&n,&m);
		for(int i=0;i<m;i++){
			int u,v;
			scanf("%d%d",&u,&v);
			side[top]=make_pair(v,node[u]);
			node[u]=top++;
		}
		tarjan();
		for(int u=1;u<=n;u++){
			for(int i=node[u];i!=-1;i=side[i].second){
				int v=side[i].first;
				if(low[u]==low[v])continue;
				else{
					in[low[v]]++;
					out[low[u]]++;
				}
			}
		}
		int count_in=0,count_out=0;
		if(cnt==1){printf("0\n");continue;}
		for(int i=0;i<cnt;i++){
			if(in[i]==0)count_in++;
			if(out[i]==0)count_out++;
		}
		printf("%d\n",max(count_in,count_out));
	}
}


發佈了46 篇原創文章 · 獲贊 4 · 訪問量 4萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章