POJ_1111_Image Perimeters【DFS】

/*
Image Perimeters
Time Limit: 1000MS        Memory Limit: 10000K
Total Submissions: 9089        Accepted: 5374

Description
Technicians in a pathology lab analyze digitized images of slides. Objects on a slide are selected for analysis by a mouse click on the object. The perimeter of the boundary of an object is one useful measure. Your task is to determine this perimeter for selected objects.

The digitized slides will be represented by a rectangular grid of periods, '.', indicating empty space, and the capital letter 'X', indicating part of an object. Simple examples are
An X in a grid square indicates that the entire grid square, including its boundaries, lies in some object. The X in the center of the grid below is adjacent to the X in any of the 8 positions around it. The grid squares for any two adjacent X's overlap on an edge or corner, so they are connected.
An object consists of the grid squares of all X's that can be linked to one another through a sequence of adjacent X's. In Grid 1, the whole grid is filled by one object. In Grid 2 there are two objects. One object contains only the lower left grid square. The remaining X's belong to the other object.

The technician will always click on an X, selecting the object containing that X. The coordinates of the click are recorded. Rows and columns are numbered starting from 1 in the upper left hand corner. The technician could select the object in Grid 1 by clicking on row 2 and column 2. The larger object in Grid 2 could be selected by clicking on row 2, column 3. The click could not be on row 4, column 3.

One useful statistic is the perimeter of the object. Assume each X corresponds to a square one unit on each side. Hence the object in Grid 1 has perimeter 8 (2 on each of four sides). The perimeter for the larger object in Grid 2 is illustrated in the figure at the left. The length is 18.

Objects will not contain any totally enclosed holes, so the leftmost grid patterns shown below could NOT appear. The variations on the right could appear:

Input
The input will contain one or more grids. Each grid is preceded by a line containing the number of rows and columns in the grid and the row and column of the mouse click. All numbers are in the range 1-20. The rows of the grid follow, starting on the next line, consisting of '.' and 'X' characters.

The end of the input is indicated by a line containing four zeros. The numbers on any one line are separated by blanks. The grid rows contain no blanks.

Output
For each grid in the input, the output contains a single line with the perimeter of the specified object.

Sample Input

2 2 2 2
XX
XX
6 4 2 3
.XXX
.XXX
.XXX
...X
..X.
X...
5 6 1 3
.XXXX.
X....X
..XX.X
.X...X
..XXX.
7 7 2 6
XXXXXXX
XX...XX
X..X..X
X..X...
X..X..X
X.....X
XXXXXXX
7 7 4 4
XXXXXXX
XX...XX
X..X..X
X..X...
X..X..X
X.....X
XXXXXXX
0 0 0 0

Sample Output

8
18
40
48
8

題目: 在圖中找  在指定座標點中 X  包含的周長。

思路 :找到聯通的 X 判斷每個 X 四周 是否有 . 有加 1  

*/

#include <cstdio>
#include <cstring>
char map[25][25];
int dir[8][2]={ 0,1, 1,1, 1,0, 1,-1, 0,-1, -1,-1, -1,0, -1,1 };
int arr[4][2]={ 0,1, 1,0, 0,-1 ,-1,0 };
int n,m,count;
void DFS(int x,int y)
{
	int r,c,i;
	map[x][y] = '#';	
	for(i=0;i<4;i++)//找每個點 上 下 左 右 是否 有 . 
	{
		r = x + arr[i][0];
		c = y + arr[i][1];
		if(map[r][c]=='.'){
			count++;
		}
	}
	
	for(i=0;i<8;i++)//找聯通 
	{
		r = x + dir[i][0];
		c = y + dir[i][1];
		if(map[r][c]=='X'){
			DFS(r,c);
		}
	}
}
int main()
{
	int i,x,y;
	while(scanf("%d%d%d%d",&n,&m,&x,&y) && n!=0 && m!=0 && x!=0 && y!=0)
	{
		memset(map,'.',sizeof(map));//把地圖初始化爲 . 
		for(i=1;i<=n;i++){
			scanf("%s",&map[i][1]); //由於是逐行讀入的數據,數據後面的 默認沒了,,, 上面初始化的...也沒了 ,這個地方卡了好久。 
			map[i][m+1] = '.';  //把每行的最後一個 在付一值  . 
		}
		count = 0;
		DFS(x,y);
		printf("%d\n",count);
	}
	return 0;
}


發佈了180 篇原創文章 · 獲贊 28 · 訪問量 9萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章