POJ_1159_Palindrome【dp】

/*Palindrome
Time Limit: 3000MS        Memory Limit: 65536K
Total Submissions: 62592        Accepted: 21811

Description
A palindrome is a symmetrical string, that is, a string read identically from left to right as well as from right to left. You are to write a program which, given a string, determines the minimal number of characters to be inserted into the string in order to obtain a palindrome.

As an example, by inserting 2 characters, the string "Ab3bd" can be transformed into a palindrome ("dAb3bAd" or "Adb3bdA"). However, inserting fewer than 2 characters does not produce a palindrome.

Input
Your program is to read from standard input. The first line contains one integer: the length of the input string N, 3 <= N <= 5000. The second line contains one string with length N. The string is formed from uppercase letters from 'A' to 'Z', lowercase letters from 'a' to 'z' and digits from '0' to '9'. Uppercase and lowercase letters are to be considered distinct.

Output
Your program is to write to standard output. The first line contains one integer, which is the desired minimal number.

Sample Input

5
Ab3bd

Sample Output

2


  題意,給你一個字符串,可在任意位置添加字符,最少再添加幾個字符,可以使這個字符串成爲迴文字符串。
 
  思路:求原串與其逆串的最長公共子序列,然後用串長減去最長公共子序列的長度就是要添加的最少的字符數。
 

*/

#include <cstdio>
#include<iostream>
#include<cstring>
#include <algorithm>
using namespace std;
const int  Max = 5005;
char str1[Max],str2[Max];
int dp[2][Max];
int main()
{
    int n,i,j,k;
    while(cin>>n)
    {
		scanf("%s",&str1[1]);
        for(i=1;i<=n;i++)//str1的逆串
            str2[i]=str1[n-i+1];
        memset(dp,0,sizeof(dp));
        i=0;
        for(k=1;k<=n;k++)
        {   
            i=1-i;//滾動數組
            for(j=1;j<=n;j++)
            {
                if(str1[k]==str2[j]) 
                    dp[i][j] = dp[1-i][j-1] + 1;
                else 
                	dp[i][j] = max(dp[i][j-1], dp[1-i][j]);  
            }
        }
        cout<<n-dp[i][n]<<endl;
    }
    return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章