POJ_2060_Taxi Cab Scheme【最小路徑覆蓋】

/*
Taxi Cab Scheme
Time Limit: 1000MS        Memory Limit: 30000K
Total Submissions: 6460        Accepted: 2720

Description
Running a taxi station is not all that simple. Apart from the obvious demand for a
centralised coordination of the cabs in order to pick up the customers calling to get a cab as soon
as possible,there is also a need to schedule all the taxi rides which have been booked in advance.
Given a list of all booked taxi rides for the next day, you want to minimise the number of cabs
needed to carry out all of the rides.
For the sake of simplicity, we model a city as a rectangular grid. An address in the city is denoted
 by two integers: the street and avenue number. The time needed to get from the address a, b to c, d
  by taxi is |a - c| + |b - d| minutes. A cab may carry out a booked ride if it is its first ride of
  the day, or if it can get to the source address of the new ride from its latest,at least one minute
   before the new ride's scheduled departure. Note that some rides may end after midnight.

Input
On the first line of the input is a single positive integer N, telling the number of test scenarios
to follow. Each scenario begins with a line containing an integer M, 0 < M < 500, being the number
of booked taxi rides. The following M lines contain the rides. Each ride is described by a departure
 time on the format hh:mm (ranging from 00:00 to 23:59), two integers a b that are the coordinates
 of the source address and two integers c d that are the coordinates of the destination address. All
 coordinates are at least 0 and strictly smaller than 200. The booked rides in each scenario are
  sorted in order of increasing departure time.

Output
For each scenario, output one line containing the minimum number of cabs required to carry out all
 the booked taxi rides.

Sample Input

2
2
08:00 10 11 9 16
08:07 9 16 10 11
2
08:00 10 11 9 16
08:06 9 16 10 11

Sample Output

1
2
題意:出租車公司有n個預約, 每個預約有時間和地點, 地點分佈在二維整數座標系上, 地點之間的行駛時間爲兩點間的曼哈頓距離
(|x1 - x2| + |y1 - y2|)。一輛車可以在運完一個乘客後運另一個乘客, 條件是此車要在預約開始前一分鐘之前到達出發地, 問最少需要幾輛車搞定所有預約。

給出一些預約的起始時間,出發地和目的地,問至少需要多少車可以滿足所有的預約
對於任何一對預約,如果前一預約的結束時刻加上到達下一個預約的所需時間小於下一個預約

的起始時間,就在兩個預約之間連一條邊,題目就轉化爲求該圖的最小路徑覆蓋

不懂的看這個知識點

*/

#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#define inf 0x3f3f3f3f
int match[610];
int map[610][610];
bool vis[610];
int n;
struct Node
{
	int start;
	int end;
	int a,b,c,d,e,f;
}edge[1220];
int cmp(const void *a,const void *b)
{
	return (*(Node *)a).start - (*(Node *)b).start;
}
int dfs(int x)
{
	int i;
	for(i=1;i<=n;i++)
	{
		if(!vis[i] && map[x][i])
		{
			vis[i] = true;
			if(!match[i] || dfs(match[i]))
			{
				match[i] = x;
				return 1;
			}
		}
	}
	return 0;
}
int main()
{
	int T;
	scanf("%d",&T);
	while(T--)
	{
		int i,j;
		scanf("%d",&n);
		for(i=1;i<=n;i++)
		{
			scanf("%d:%d%d%d%d%d",&edge[i].a,&edge[i].b,&edge[i].c,&edge[i].d,&edge[i].e,&edge[i].f);
			edge[i].start = edge[i].a*60+edge[i].b; //起始時間
			edge[i].end = edge[i].start + abs(edge[i].e-edge[i].c) + abs(edge[i].f-edge[i].d);//結束時間
		}
		qsort(edge+1,n,sizeof(edge[0]),cmp);
		memset(map,0,sizeof(map));
		for(i=1;i<n;i++)
		{
			for(j=i+1;j<=n;j++)
			{
				int t = abs(edge[i].e-edge[j].c) + abs(edge[i].f-edge[j].d);
				if(edge[i].end+t < edge[j].start)//前一預約的結束時刻加上到達下一個預約的所需時間  小於下一個預約的起始時間, 
				{
					map[i][j] = 1;
				}
			}
		}
		memset(match,0,sizeof(match));
		int ans = 0;
		for(i=1;i<=n;i++)
		{
			memset(vis,false,sizeof(vis));
			if(dfs(i))
			{
				ans ++ ;
			}
		}
		printf("%d\n",n-ans);
	}
	return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章