1146 Topological Order (25 分) 判斷是否爲拓撲序列

1146 Topological Order (25 分)

This is a problem given in the Graduate Entrance Exam in 2018: Which of the following is NOT a topological order obtained from the given directed graph? Now you are supposed to write a program to test each of the options.

gre.jpg

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N (≤ 1,000), the number of vertices in the graph, and M (≤ 10,000), the number of directed edges. Then M lines follow, each gives the start and the end vertices of an edge. The vertices are numbered from 1 to N. After the graph, there is another positive integer K (≤ 100). Then K lines of query follow, each gives a permutation of all the vertices. All the numbers in a line are separated by a space.

Output Specification:

Print in a line all the indices of queries which correspond to "NOT a topological order". The indices start from zero. All the numbers are separated by a space, and there must no extra space at the beginning or the end of the line. It is graranteed that there is at least one answer.

Sample Input:

6 8
1 2
1 3
5 2
5 4
2 3
2 6
3 4
6 4
5
1 5 2 3 6 4
5 1 2 6 3 4
5 1 2 3 6 4
5 2 1 6 3 4
1 2 3 4 5 6

Sample Output:

3 4

聽說有一題考拓撲排序的,特地來看看,果然很簡單。直接考拓撲排序太老套,本題懂拓撲排序的大致算法即可做

#include<bits/stdc++.h>
using namespace std;

const int maxn=1010;
vector<int> Adj[maxn];
int n,m;
int inDegree[maxn]={0},A[maxn];

void print(int a[]){
	for(int i=1;i<=n;i++) cout<<a[i]<<" ";
	cout<<endl;
}

int main(){
//	freopen("in.txt","r",stdin);
	cin>>n>>m;
	int a,b;
	while(m--){
		scanf("%d%d",&a,&b);
		Adj[a].push_back(b);//a->b
		inDegree[b]++;
	} 
	int k;
	vector<int> ans;
	int degree[maxn];
	
	cin>>k;
	for(int t=0;t<k;t++){
		for(int i=0;i<n;i++){
			scanf("%d",&A[i]);
		}
		for(int i=1;i<=n;i++) degree[i]=inDegree[i];
		
		for(int i=0;i<n;i++){
			if(degree[A[i]]!=0){
				ans.push_back(t);
				break;
			}
			vector<int> ve=Adj[A[i]];
			for(int j=0;j<ve.size();j++){
				degree[ve[j]]--;
			}
		}
	}
	
	for(int i=0;i<ans.size();i++){
		 if(i>0) printf(" ");
		 printf("%d",ans[i]); 
	} 
	
	return 0;
}

 

發佈了388 篇原創文章 · 獲贊 89 · 訪問量 9萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章