POJ - 2421 Constructing Roads(最小生成樹 prim算法)

Constructing Roads
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 25971 Accepted: 11367

Description

There are N villages, which are numbered from 1 to N, and you should build some roads such that every two villages can connect to each other. We say two village A and B are connected, if and only if there is a road between A and B, or there exists a village C such that there is a road between A and C, and C and B are connected. 

We know that there are already some roads between some villages and your job is the build some roads such that all the villages are connect and the length of all the roads built is minimum.

Input

The first line is an integer N (3 <= N <= 100), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 1000]) between village i and village j. 

Then there is an integer Q (0 <= Q <= N * (N + 1) / 2). Then come Q lines, each line contains two integers a and b (1 <= a < b <= N), which means the road between village a and village b has been built.

Output

You should output a line contains an integer, which is the length of all the roads to be built such that all the villages are connected, and this value is minimum.

Sample Input

3
0 990 692
990 0 179
692 179 0
1
1 2

Sample Output

179

Code

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#define N 110
#define INF 0x3f3f3f3f

using namespace std;

int map[N][N];
int vis[N];
int dis[N];
int ans,n;

void prim()
{
    int i,j,min,pos;
    for(i=1; i<=n; i++)
    {
        dis[i] = map[1][i];
        vis[i] = 0;
    }
    vis[1] = 1;
    for(i=1; i<=n-1; i++)
    {
        min = INF;
        for(j=1; j<=n; j++)
        {
            if(!vis[j] && dis[j] < min)
            {
                min = dis[j];
                pos = j;
            }
        }
        ans += min;
        vis[pos] = 1;
        for(j=1; j<=n; j++)
        {
            if(!vis[j] && dis[j] > map[pos][j])
            {
                dis[j] = map[pos][j];
            }
        }
    }
}

int main()
{
    int m,i,j,a,b;
    while(~scanf("%d",&n))
    {
        ans = 0;
        for(i=1; i<=n; i++)
        {
            for(j=1; j<=n; j++)
            {
                scanf("%d",&map[i][j]);
            }
        }
        scanf("%d",&m);
        while(m--)
        {
            scanf("%d %d",&a,&b);
            map[a][b] = map[b][a] = 0;
        }
        prim();
        printf("%d\n",ans);
    }
    return 0;
}

反思:

題目大意:多組輸入,給出圖的點數n和圖的鄰接矩陣,接下來有m組數據,每組包含a和b兩個整數,說明a和b兩個村莊連通。最小生成樹模板題,因爲題目給出了鄰接矩陣,所以連圖的初始化都省了♪(゚▽^*)ノ⌒☆。已經連通的兩個村莊權值置爲0,然後用prim即可。

發佈了112 篇原創文章 · 獲贊 8 · 訪問量 4萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章