ZOJ - 1586 QS Network(最小生成樹 prim算法)

QS Network

Time Limit: 2 Seconds      Memory Limit: 65536 KB

Sunny Cup 2003 - Preliminary Round

April 20th, 12:00 - 17:00

Problem E: QS Network


In the planet w-503 of galaxy cgb, there is a kind of intelligent creature named QS. QScommunicate with each other via networks. If two QS want to get connected, they need to buy two network adapters (one for each QS) and a segment of network cable. Please be advised that ONE NETWORK ADAPTER CAN ONLY BE USED IN A SINGLE CONNECTION.(ie. if a QS want to setup four connections, it needs to buy four adapters). In the procedure of communication, a QS broadcasts its message to all the QS it is connected with, the group of QS who receive the message broadcast the message to all the QS they connected with, the procedure repeats until all the QS's have received the message.

A sample is shown below:


A sample QS network, and QS A want to send a message.

Step 1. QS A sends message to QS B and QS C;

Step 2. QS B sends message to QS A ; QS C sends message to QS A and QS D;

Step 3. the procedure terminates because all the QS received the message.

Each QS has its favorate brand of network adapters and always buys the brand in all of its connections. Also the distance between QS vary. Given the price of each QS's favorate brand of network adapters and the price of cable between each pair of QS, your task is to write a program to determine the minimum cost to setup a QS network.


Input

The 1st line of the input contains an integer t which indicates the number of data sets.

From the second line there are t data sets.

In a single data set,the 1st line contains an interger n which indicates the number of QS.

The 2nd line contains n integers, indicating the price of each QS's favorate network adapter.

In the 3rd line to the n+2th line contain a matrix indicating the price of cable between ecah pair of QS.

Constrains:

all the integers in the input are non-negative and not more than 1000.


Output

for each data set,output the minimum cost in a line. NO extra empty lines needed.


Sample Input

1
3
10 20 30
0 100 200
100 0 300
200 300 0


Sample Output

370

Code
#include <cstdio>
#include <cstring>
#include <cmath>
#define N 1010
#define INF 0x3f3f3f3f

using namespace std;

int map[N][N];  ///保存每個QS之間的電纜的價格
int adp[N];     ///保存每個QS網絡適配器的價格
int dis[N];
int vis[N];

void prim(int n)
{
    int i,j,pos,min,ans = 0;
    ///兩個QS建立聯繫時,需要兩個適配器
    for(i=1; i<=n; i++)
    {
        dis[i] = map[1][i] + adp[1] + adp[i];
        vis[i] = 0;
    }
    vis[1] = 1;
    for(i=1; i<=n; i++)
    {
        min = INF;
        for(j=1; j<=n; j++)
        {
            if(!vis[j] && dis[j] < min)
            {
                min = dis[j];
                pos = j;
            }
        }
        if(min != INF)
        {
            ans += min;
            vis[pos] = 1;
            for(j=1; j<=n; j++)
            {
                if(!vis[j] && dis[j] > map[pos][j] + adp[j] + adp[pos])
                {
                    dis[j] = map[pos][j] + adp[j] + adp[pos];
                }
            }
        }
    }
    printf("%d\n",ans);
}

int main()
{
    int t,i,j,n;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        for(i=1; i<=n; i++)
        {
            scanf("%d",&adp[i]);
        }
        for(i=1; i<=n; i++)
        {
            for(j=1; j<=n; j++)
            {
                scanf("%d",&map[i][j]);
            }
        }
        prim(n);
    }
    return 0;
}
反思:

題目大意:在星球w-503上,有種智能生物-QS通過網絡通信。兩個QS之間通信需要網絡適配器和網絡電纜。網絡適配器是單向鏈接的(有向圖),而且不同QS之間需要的網絡適配器不同,要求讓所有QS通信的最低成本。第一行是數據組數t,每組數據中,第一行是QS數量n,第二行有n個數據,代表每個QS的網絡適配器的價格,剩下的幾行是網絡電纜價格的鄰接矩陣。和一般的prim略有些不同,要在求電纜最低價格的同時算上網絡適配器的價格(初始化和更新dis數組時),因爲是單向的還得算上兩個……不過還是最小生成樹模板題。
發佈了112 篇原創文章 · 獲贊 8 · 訪問量 4萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章