EASY_ZJU_PAT_ADVANCED LEVEL 1050 高效输入含有空格的字符串 高效删除字符串中的字符

1050. String Subtraction (20)

时间限制
10 ms
内存限制
32000 kB
代码长度限制
16000 B
判题程序
Standard

Given two strings S1 and S2, S = S1 - S2 is defined to be the remaining string after taking all the characters in S2 from S1. Your task is simply to calculate S1 - S2 for any given strings. However, it might not be that simple to do it fast.

Input Specification:

Each input file contains one test case. Each case consists of two lines which gives S1 and S2, respectively. The string lengths of both strings are no more than 104. It is guaranteed that all the characters are visible ASCII codes and white space, and a new line character signals the end of a string.

Output Specification:

For each test case, print S1 - S2 in one line.

Sample Input:
They are students.
aeiou
Sample Output:
Thy r stdnts.
NOTE:
1.通常的cin和scanf("%s",*char)这种遇到空格会停止,有系统内置的函数可以实现连续带空格的输入,gets(char*)和getline(cin,string),但是这两种的效率都不是很高。可以用
	while(scanf("%c",*char)&&ch!='\n'){
	}
	这种形式进行带有空格的字符串输入
2.这道题思路不难,但是重点就在如何减少运行时间。要不然会出现超时的情况。
/************************************************
	@ AUTHOR	: GAOMINQUAN
	@ DATA		: 2014 - 2 - 24
	@ MAIL		: [email protected]
	@ HARD		: EASY ***

/************************************************/
#include<iostream>
#include<vector>
#include<string.h>
using namespace std;
const int M = 10000;
const int charNum = 127;
int main(){
	char line1[M];
	vector<int> charMark(charNum,0);
	char ch;
	int index1 = 0;

	while(scanf("%c",&ch)&&ch!='\n'){
		line1[index1++] = ch;
	}
	while(scanf("%c",&ch)&&ch!='\n'){
		int index = ch;
		charMark[index] = -1;
	}

	for(int line1Index = 0; line1Index<index1; line1Index++){
		int index = line1[line1Index];
		if(charMark[index] == 0){
			printf("%c",line1[line1Index]);
		}
	}
	cout<<endl;
	return 0;

}


发布了40 篇原创文章 · 获赞 3 · 访问量 8万+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章