EAST_ZJU_PAT_DAVANCED LEVEL_1035 利用面向對象,化簡分析過程

1035. Password (20)

時間限制
400 ms
內存限制
32000 kB
代碼長度限制
16000 B
判題程序
Standard
作者
CHEN, Yue

To prepare for PAT, the judge sometimes has to generate random passwords for the users. The problem is that there are always some confusing passwords since it is hard to distinguish 1 (one) from l (L in lowercase), or 0 (zero) from O (o in uppercase). One solution is to replace 1 (one) by @, 0 (zero) by %, l by L, and O by o. Now it is your job to write a program to check the accounts generated by the judge, and to help the juge modify the confusing passwords.

Input Specification:

Each input file contains one test case. Each case contains a positive integer N (<= 1000), followed by N lines of accounts. Each account consists of a user name and a password, both are strings of no more than 10 characters with no space.

Output Specification:

For each test case, first print the number M of accounts that have been modified, then print in the following M lines the modified accounts info, that is, the user names and the corresponding modified passwords. The accounts must be printed in the same order as they are read in. If no account is modified, print in one line "There are N accounts and no account is modified" where N is the total number of accounts. However, if N is one, you must print "There is 1 account and no account is modified" instead.

Sample Input 1:

3
Team000002 Rlsp0dfa
Team000003 perfectpwd
Team000001 R1spOdfa
Sample Output 1:
2
Team000002 RLsp%dfa
Team000001 R@spodfa
Sample Input 2:
1
team110 abcdefg332
Sample Output 2:
There is 1 account and no account is modified
Sample Input 3:
2
team110 abcdefg222
team220 abcdefg333
Sample Output 3:
There are 2 accounts and no account is modified

/******************************88

	@ NAME	:GAOMINQUAN
	@ MAIL	:[email protected]
	@ DATA	:2014 - 2- 23	
	@ HARD	:EASY **
*******************************/

#include<iostream>
#include<string>
#include<vector>

using namespace std;

struct person{
	string id;
	vector<char> passWord;
	bool modified;
	person(){
		string id,passWord;
		cin>>id>>passWord;
		
		this-> id = id;
		this-> modified = false;

		for(int stringIndex = 0; stringIndex < passWord.size(); stringIndex ++){
			this->passWord.push_back(passWord[stringIndex]);
		}	
	};

	void printInfo(){		
		cout<<this->id<<" ";
		for(int psIndex = 0; psIndex < passWord.size(); psIndex++){
			cout<<this->passWord[psIndex];
		}cout<<endl;
	};

	bool changePassword(){
		char changeChar[] = {'1','l','0','O'};
		char newChar[] = {'@','L','%','o'};

		bool modified = false;

		for(int psIndex = 0; psIndex<this->passWord.size(); psIndex++){
			for(int charIndex = 0; charIndex < sizeof(changeChar)/sizeof(changeChar[0]); charIndex++){
				if( changeChar[charIndex] == this->passWord[psIndex]){
					this->passWord[psIndex] = newChar[charIndex];
					modified = true;
					this->modified = true;
				}
			}
		}

		return modified;
	};

};
void printAllInfo(vector<person> persons,int mNum);

int main(){
	bool haveModified;
	int M = 0;
	cin>>M;
	
	vector<person> account;
	
	int changedNum = 0;

	for(int accIndex = 0; accIndex < M; accIndex++){
		person tempP = person();
		if(tempP.changePassword()){
			changedNum++;
		}
		account.push_back(tempP);
	}

	printAllInfo(account,changedNum);

}

void printAllInfo(vector<person> persons,int mNum){
	if(mNum == 0){
		if(persons.size() == 1){
			cout<<"There is 1 account and no account is modified"<<endl;
		}else{
			cout<<"There are "<<persons.size()<<" accounts and no account is modified"<<endl;
		}
	}else{
		cout<<mNum<<endl;
		for(int personIndex = 0; personIndex<persons.size(); personIndex++){
			if(persons[personIndex].modified){
				persons[personIndex].printInfo();
			}
		}
	}
}


	
NOTE:
注意單複數 is are以及格式的統一

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章