EASY_ZJU_PAT ADVANCED LEVEL_1031 仔細分析,刪繁就簡

1031. Hello World for U (20)

時間限制
400 ms
內存限制
32000 kB
代碼長度限制
16000 B
判題程序
Standard
作者
CHEN, Yue

Given any string of N (>=5) characters, you are asked to form the characters into the shape of U. For example, "helloworld" can be printed as:

h  d
e  l
l  r
lowo
That is, the characters must be printed in the original order, starting top-down from the left vertical line with n1 characters, then left to right along the bottom line with n2 characters, and finally bottom-up along the vertical line with n3 characters. And more, we would like U to be as squared as possible -- that is, it must be satisfied that n1 = n3 = max { k| k <= n2 for all 3 <= n2 <= N } with n1 + n2 + n3 - 2 = N.

Input Specification:

Each input file contains one test case. Each case contains one string with no less than 5 and no more than 80 characters in a line. The string contains no white space.

Output Specification:

For each test case, print the input string in the shape of U as specified in the description.

Sample Input:
helloworld!
Sample Output:
h   !
e   d
l   l
lowor
/*
	@ AUTHOR	:GAOMINQUAN
	@ DATA		:2014-2-24
	@ HARD		:EASY ***
	@ MAIL		:ENSOLEILLY
*/
#include<iostream>
#include<string>
using namespace std;
int main(){
	string input = "helloWorld";	
	cin>>input;
	int N1 = (input.size()+2)/3;
	int N2 = N1 + (input.size()+2)%3;
	int span = N2 - 2, index = 0;

	for(int line = 0; line<N1-1; line++){
		cout<<input[index];
		for(int sIndex = 0; sIndex <span; sIndex++){
			cout<<" ";
		}
		cout<<input[input.size()-1-index]<<endl;
		index++;
	}

	for(int n2Index = 0; n2Index<N2; n2Index++){
		cout<<input[index++];
	}
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章