Palindrome subsequence(區間dp)

http://acm.hdu.edu.cn/showproblem.php?pid=4632

Palindrome subsequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/65535 K (Java/Others)
Total Submission(s): 2764    Accepted Submission(s): 1121


Problem Description
In mathematics, a subsequence is a sequence that can be derived from another sequence by deleting some elements without changing the order of the remaining elements. For example, the sequence <A, B, D> is a subsequence of <A, B, C, D, E, F>.
(http://en.wikipedia.org/wiki/Subsequence)

Given a string S, your task is to find out how many different subsequence of S is palindrome. Note that for any two subsequence X = <Sx1, Sx2, ..., Sxk> and Y = <Sy1, Sy2, ..., Syk> , if there exist an integer i (1<=i<=k) such that xi != yi, the subsequence X and Y should be consider different even if Sxi = Syi. Also two subsequences with different length should be considered different.
 

Input
The first line contains only one integer T (T<=50), which is the number of test cases. Each test case contains a string S, the length of S is not greater than 1000 and only contains lowercase letters.
 

Output
For each test case, output the case number first, then output the number of different subsequence of the given string, the answer should be module 10007.
 

Sample Input
4 a aaaaa goodafternooneveryone welcometoooxxourproblems
 

Sample Output
Case 1: 1 Case 2: 31 Case 3: 421 Case 4: 960
 

區間dp.

題意:求一字符串中迴文子序列的數目。

題解:dp[i][j]=dp[i+1][j]+dp[i][j-1]-dp[i+1][j-1]; 注意s[i]=s[j]時,dp[i][j]=dp[i+1][j-1]+1.


#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<cmath>
#include<queue>
#include<cstdlib>
#include<string>

#define maxn 1005
const int mod=10007;
using namespace std;

char s[maxn];
int dp[maxn][maxn];
int main()
{
    int n,m;
    while(~scanf("%d",&n))
    {
        m=1;
       while(n--)
       {
           scanf("%s",s);
           int l=strlen(s);
           memset(dp,0,sizeof(dp));
           for(int i=0;i<l;i++)
            dp[i][i]=1;
           for(int j=0;j<l;j++)
            for(int i=j-1;i>=0;i--)
           {
              dp[i][j]=(dp[i+1][j]+dp[i][j-1]-dp[i+1][j-1]+mod)%mod;
              if(s[i]==s[j])
                dp[i][j]=(dp[i][j]+dp[i+1][j-1]+1+mod)%mod;
           }
           printf("Case %d: %d\n",m++,dp[0][l-1]);
       }
    }
    return 0;
}


發佈了35 篇原創文章 · 獲贊 10 · 訪問量 2萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章