HDU 1087

Description

Nowadays, a kind of chess game called “Super Jumping! Jumping! Jumping!” is very popular in HDU. Maybe you are a good boy, and know little about this game, so I introduce it to you now.



The game can be played by two or more than two players. It consists of a chessboard(棋盤)and some chessmen(棋子), and all chessmen are marked by a positive integer or “start” or “end”. The player starts from start-point and must jumps into end-point finally. In the course of jumping, the player will visit the chessmen in the path, but everyone must jumps from one chessman to another absolutely bigger (you can assume start-point is a minimum and end-point is a maximum.). And all players cannot go backwards. One jumping can go from a chessman to next, also can go across many chessmen, and even you can straightly get to end-point from start-point. Of course you get zero point in this situation. A player is a winner if and only if he can get a bigger score according to his jumping solution. Note that your score comes from the sum of value on the chessmen in you jumping path.
Your task is to output the maximum value according to the given chessmen list.
 

Input

Input contains multiple test cases. Each test case is described in a line as follow:
N value_1 value_2 …value_N
It is guarantied that N is not more than 1000 and all value_i are in the range of 32-int.
A test case starting with 0 terminates the input and this test case is not to be processed.
 

Output

For each case, print the maximum according to rules, and one line one case.
 

Sample Input

3 1 3 2 4 1 2 3 4 4 3 3 2 1 0
 

Sample Output

4 10 3
 

**題意:第一個數代表數組的的個數,接下來的數字是一個數組,求這個數組的最長上升子序列的和**

**沒什麼難的,水題,都是模板**

import java.util.Arrays;
import java.util.Scanner;

public class Main{
    private static int num = 0;
    private static int[] array = new int[10010];
   
    private static int[] temp_array = new int[10010];

    public static void main(String[] args) {
	Scanner scanner = new Scanner(System.in);
	while (true) {
	    num = scanner.nextInt();
	    init();
	    if (num == 0)
		break;
	    for (int i = 0; i < num; i++) {
		array[i] = scanner.nextInt();		
	    }
	    for (int i = 0; i < num; i++) {
		temp_array[i] = array[i];
		for (int j = i-1; j >=0; j--) {
		    if (array[j]<array[i]&&temp_array[j]+array[i]>temp_array[i]) {
			temp_array[i] = temp_array[j] +array[i];
		    }
		}
	    }
	    int sum =temp_array[0];
	    for (int i = 0; i <num; i++) {
		if (sum<temp_array[i]) {
		    sum = temp_array[i];
		}
	    }
	    System.out.println(sum);
	}
	scanner.close();
	   
    }


    private static void init() {
	Arrays.fill(array, 0);
	Arrays.fill(temp_array, 0);
	
    }

}



發佈了41 篇原創文章 · 獲贊 119 · 訪問量 17萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章