POJ 1862

Stripies
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 14292 Accepted: 6707

Description
Our chemical biologists have invented a new very useful form of life called stripies (in fact, they were first called in Russian - polosatiki, but the scientists had to invent an English name to apply for an international patent). The stripies are transparent amorphous amebiform creatures that live in flat colonies in a jelly-like nutrient medium. Most of the time the stripies are moving. When two of them collide a new stripie appears instead of them. Long observations made by our scientists enabled them to establish that the weight of the new stripie isn’t equal to the sum of weights of two disappeared stripies that collided; nevertheless, they soon learned that when two stripies of weights m1 and m2 collide the weight of resulting stripie equals to 2*sqrt(m1*m2). Our chemical biologists are very anxious to know to what limits can decrease the total weight of a given colony of stripies.
You are to write a program that will help them to answer this question. You may assume that 3 or more stipies never collide together.

Input
The first line of the input contains one integer N (1 <= N <= 100) - the number of stripies in a colony. Each of next N lines contains one integer ranging from 1 to 10000 - the weight of the corresponding stripie.

Output
The output must contain one line with the minimal possible total weight of colony with the accuracy of three decimal digits after the point.

Sample Input

3
72
30
50

Sample Output

120.000

題意: 給出n 個物體,分別給出每個的質量,並且兩個物體(假設質量分別爲m1,m2)相撞的時候變成一個物體,質量爲2*sqrt(m1*m2),並且只會出現兩個兩個物品碰撞的情況,問最終能得到的物體的最小質量是多少。
思路:其實就是講一個長度爲n的數組降 排降序 然後對每次的數組進行 num=2.0*sqrt(num*a[i]);的操作

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <algorithm>
#include <map>
#include <cmath>
using namespace std;
int n;
int a[105];
int b[105];
double result,num;
int cmp(int a,int b)
{
    return a>b;
}
void init()
{
    for(int i=0;i<n;i++)
        b[i]=0;
}
int main()
{
    while(~scanf("%d",&n))
    {
        for(int i=0;i<n;i++)
            scanf("%d",&a[i]);
            init();
        sort(a,a+n,cmp);
        int i=0;
        num=a[0];
        for(int i=1;i<n;i++)
        {
            num=2.0*sqrt(num*a[i]);
        }
        printf("%0.3lf\n",num);
    }
    return 0;
}
發佈了41 篇原創文章 · 獲贊 119 · 訪問量 17萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章