POJ 1159

Description
A palindrome is a symmetrical string, that is, a string read identically from left to right as well as from right to left. You are to write a program which, given a string, determines the minimal number of characters to be inserted into the string in order to obtain a palindrome.

As an example, by inserting 2 characters, the string “Ab3bd” can be transformed into a palindrome (“dAb3bAd” or “Adb3bdA”). However, inserting fewer than 2 characters does not produce a palindrome.

Input
Your program is to read from standard input. The first line contains one integer: the length of the input string N, 3 <= N <= 5000. The second line contains one string with length N. The string is formed from uppercase letters from ‘A’ to ‘Z’, lowercase letters from ‘a’ to ‘z’ and digits from ‘0’ to ‘9’. Uppercase and lowercase letters are to be considered distinct.

Output
Your program is to write to standard output. The first line contains one integer, which is the desired minimal number.

Sample Input

5
Ab3bd

Sample Output

2

題意:
給出一串字符串字母,問最少添加多少字母能把這個字符串變成迴文串,相信對於迴文串,大家都瞭解,所以就不贅述了*

思路:
也是看了大神的博客才做出來的,最主要的就是最少次數 = 字符串長度 - 字符串倒敘與 字符串正序的最長公共字串長度*

代碼:


import java.util.Scanner;

public class Main{
    private static int num = 0;
    private static char[] array_a = new char[5005];
    private static char[] array_b = new char[5005];
    private static int[][] cc = new int[2][5005];
    public static void main(String[] args) {
    Scanner scanner = new Scanner(System.in);
    num = scanner.nextInt();
    String inputLine = scanner.next();
    array_a = inputLine.toCharArray();
    int data = 0;
    for (int i = inputLine.length() - 1; i >= 0; i--) {
        array_b[data++] = array_a[i];
        cc[0][i] = 0;
    }
    for (int j = 0; j < num; j++) {
        for (int i = 0; i < num; i++) {
        if (array_a[i] == array_b[j]) {
            cc[1][i + 1] = cc[0][i] + 1;
        } else {
            cc[1][i + 1] = cc[1][i] > cc[0][i + 1] ? cc[1][i]:cc[0][i + 1];
        }
        }
        for (int i = 1; i <= num; i++) {
        cc[0][i] = cc[1][i];
        }
    }
    System.out.println(num - cc[1][num]);
    scanner.close();
    }
}
發佈了41 篇原創文章 · 獲贊 119 · 訪問量 17萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章