POJ 2524 Ubiquitous Religions(並查集)

Description

There are so many different religions in the world today that it is difficult to keep track of them all. You are interested in finding out how many different religions students in your university believe in. 

You know that there are n students in your university (0 < n <= 50000). It is infeasible for you to ask every student their religious beliefs. Furthermore, many students are not comfortable expressing their beliefs. One way to avoid these problems is to ask m (0 <= m <= n(n-1)/2) pairs of students and ask them whether they believe in the same religion (e.g. they may know if they both attend the same church). From this data, you may not know what each person believes in, but you can get an idea of the upper bound of how many different religions can be possibly represented on campus. You may assume that each student subscribes to at most one religion.

Input

The input consists of a number of cases. Each case starts with a line specifying the integers n and m. The next m lines each consists of two integers i and j, specifying that students i and j believe in the same religion. The students are numbered 1 to n. The end of input is specified by a line in which n = m = 0.

Output

For each test case, print on a single line the case number (starting with 1) followed by the maximum number of different religions that the students in the university believe in.

Sample Input

10 9
1 2
1 3
1 4
1 5
1 6
1 7
1 8
1 9
1 10
10 4
2 3
4 5
4 8
5 8
0 0

Sample Output

Case 1: 1
Case 2: 7

Hint

Huge input, scanf is recommended.

很簡單的一道題,採用並查集很快即可求解。

代碼如下:

#include<iostream>
#include<cstdio>
#include<algorithm>
using namespace std;
const int MAX_N = 50010;
int set[MAX_N];
int height[MAX_N];
void init(int n)
{
    for (int i = 0; i < n;i++)
    {
        set[i] = i;
        height[i] = 1;
    }
}
int cha(int x)
{
    int r = x;
    while (set[r] != r)
        r = set[r];
    int i = x;
    while (set[i] != r)
    {
        i = set[i];
        set[i] = r;
    }
    return r;
}
void unite(int x, int y)
{
    x = cha(x);
    y = cha(y);
    if (x == y)
    {
        return;
    }
    if (height[x] < height[y])
    {
        set[x] = y;
    }
    else
    {
        set[y] = x;
        if (height[x] == height[y])
            height[x] ++;
    }
}
int main()
{
#ifdef ONLINE_JUDGE
#else
    freopen("D:\\in.txt", "r", stdin);
    freopen("D:\\out.txt", "w", stdout);
#endif
    int n(0), m(0);
    int a(0), b(0);
    int cnt(0);

    while (scanf("%d%d",&n,&m)!=EOF)
    {
        if (n == 0 && m == 0)
            break;
        init(n+1);
        cnt++;
        int ans(0);
        for (int i = 0; i < m; i++)
        {
            scanf("%d%d", &a, &b);
            unite(a, b);
        }
        for (int i = 1; i <=n; i++)
        {
            if (set[i] == i)
                ans++;
        }
        printf("Case %d: %d\n", cnt, ans);
    }
    return 0;
}


發佈了86 篇原創文章 · 獲贊 10 · 訪問量 11萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章