POJ 2828 - Buy Tickets(线段树)

Buy Tickets
Time Limit: 4000MS Memory Limit: 65536K
Total Submissions: 19367 Accepted: 9587
Description

Railway tickets were difficult to buy around the Lunar New Year in China, so we must get up early and join a long queue…

The Lunar New Year was approaching, but unluckily the Little Cat still had schedules going here and there. Now, he had to travel by train to Mianyang, Sichuan Province for the winter camp selection of the national team of Olympiad in Informatics.

It was one o’clock a.m. and dark outside. Chill wind from the northwest did not scare off the people in the queue. The cold night gave the Little Cat a shiver. Why not find a problem to think about? That was none the less better than freezing to death!

People kept jumping the queue. Since it was too dark around, such moves would not be discovered even by the people adjacent to the queue-jumpers. “If every person in the queue is assigned an integral value and all the information about those who have jumped the queue and where they stand after queue-jumping is given, can I find out the final order of people in the queue?” Thought the Little Cat.

Input

There will be several test cases in the input. Each test case consists of N + 1 lines where N (1 ≤ N ≤ 200,000) is given in the first line of the test case. The next N lines contain the pairs of values Posi and Vali in the increasing order of i (1 ≤ i ≤ N). For each i, the ranges and meanings of Posi and Vali are as follows:

Posi ∈ [0, i − 1] — The i-th person came to the queue and stood right behind the Posi-th person in the queue. The booking office was considered the 0th person and the person at the front of the queue was considered the first person in the queue.
Vali ∈ [0, 32767] — The i-th person was assigned the value Vali.
There no blank lines between test cases. Proceed to the end of input.

Output

For each test cases, output a single line of space-separated integers which are the values of people in the order they stand in the queue.

Sample Input

4
0 77
1 51
1 33
2 69
4
0 20523
1 19243
1 3890
0 31492
Sample Output

77 33 69 51
31492 20523 3890 19243
Hint

The figure below shows how the Little Cat found out the final order of people in the queue described in the first test case of the sample input.

这里写图片描述

题意:
有一个队列,给出n个人,每个人都要插队到某一位置,问最后队列.

解题思路:
从后往前遍历,那么对于每一个人来说,要插入第n个位置,就是插入位置到队首有n个空位.
所以用线段树去维护当前区域有多少个空位.
如果左子树的空位数大于等于插入的位置,就在前半部分插入,否则在后半部分插入.

AC代码:

#include<stdio.h>
#define lson l,mid,rt<<1
#define rson mid+1,r,rt<<1|1
const int maxn = 2e5+5;
int SegTree[maxn<<2];
int book[maxn<<2];
struct node
{
    int pos;
    int num;
}a[maxn];
void PushUp(int rt){SegTree[rt] = SegTree[rt<<1]+SegTree[rt<<1|1];}
void build(int l,int r,int rt)
{
    SegTree[rt] = r-l+1;
    if(l == r)  return ;
    int mid = (l+r)>>1;
    build(lson);
    build(rson);
}
void update(int pos,int num,int l,int r,int rt)
{
    if(l == r){book[rt] = num;SegTree[rt]--;return ;}
    int mid = (l+r)>>1;
    if(SegTree[rt<<1] >= pos)  update(pos,num,lson);
    else                    update(pos-SegTree[rt<<1],num,rson);
    PushUp(rt);
}
void print(int l,int r,int rt)
{
    if(l == r){printf("%d ",book[rt]);return ;}
    int mid = (l+r)>>1;
    print(lson);
    print(rson);
}
int main()
{
    int n;
    while(~scanf("%d",&n))
    {
        build(1,n,1);
        for(int i = 1;i <= n;i++)   scanf("%d%d",&a[i].pos,&a[i].num);
        for(int i = n;i >= 1;i--)   update(a[i].pos+1,a[i].num,1,n,1);
        print(1,n,1);
        putchar('\n');
    }
    return 0;
}
发布了172 篇原创文章 · 获赞 7 · 访问量 4万+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章