HDU3047 Zjnu Stadium(帶權並查集)

Zjnu Stadium

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3973 Accepted Submission(s): 1519

Problem Description
In 12th Zhejiang College Students Games 2007, there was a new stadium built in Zhejiang Normal University. It was a modern stadium which could hold thousands of people. The audience Seats made a circle. The total number of columns were 300 numbered 1–300, counted clockwise, we assume the number of rows were infinite.
These days, Busoniya want to hold a large-scale theatrical performance in this stadium. There will be N people go there numbered 1–N. Busoniya has Reserved several seats. To make it funny, he makes M requests for these seats: A B X, which means people numbered B must seat clockwise X distance from people numbered A. For example: A is in column 4th and X is 2, then B must in column 6th (6=4+2).
Now your task is to judge weather the request is correct or not. The rule of your judgement is easy: when a new request has conflicts against the foregoing ones then we define it as incorrect, otherwise it is correct. Please find out all the incorrect requests and count them as R.

Input
There are many test cases:
For every case:
The first line has two integer N(1<=N<=50,000), M(0<=M<=100,000),separated by a space.
Then M lines follow, each line has 3 integer A(1<=A<=N), B(1<=B<=N), X(0<=X<300) (A!=B), separated by a space.

Output
For every case:
Output R, represents the number of incorrect request.

Sample Input
10 10
1 2 150
3 4 200
1 5 270
2 6 200
6 5 80
4 7 150
8 9 100
4 8 50
1 7 100
9 2 100

Sample Output
2
Hint

Hint:
(PS: the 5th and 10th requests are incorrect)

Source
2009 Multi-University Training Contest 14 - Host by ZJNU

Recommend
gaojie | We have carefully selected several similar problems for you: 3172 3038 2473 3045 3046

題意:

題目有點怪,其實是一個半徑無限大的圓,然後每個圓周有300個位置,是連續的(想想看長得比較像漩渦),然後就給區間判斷會不會有衝突,

問題就變得和普通帶權並查集就一模一樣了,和食物鏈和奇偶性就完全一樣了。

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream>
#include<map> 
using namespace std;
typedef long long LL;
const int maxn=1e5+5,mod=300;
int fa[maxn],d[maxn],n,m,x,y,z;

inline int get(int u)
{
  if(fa[u]==u)return u;
  int f=fa[u];
  fa[u]=get(fa[u]);
  d[u]=(d[f]+d[u])%mod;
  return fa[u];
}

int main()
{
  while(~scanf("%d%d",&n,&m))
  {
    for(int i=1;i<=n;++i)fa[i]=i,d[i]=0;
    int cnt=0;
    for(int i=1;i<=m;++i)
    {
      scanf("%d%d%d",&x,&y,&z); 
      int fx=get(x),fy=get(y);
      if(fx!=fy)
      {
        fa[fy]=fx;
        d[fy]=((z-d[y]+d[x])%mod+mod)%mod;
      }
      else 
      {
        if(((d[y]-d[x])%mod+mod)%mod!=z)++cnt;
        //printf("%d\n",i);
      }
    }
    printf("%d\n",cnt);
  }
  return 0;
}
發佈了62 篇原創文章 · 獲贊 2 · 訪問量 8364
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章