POJ-1654Area(求多邊形面積)

Area
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 20510 Accepted: 5594
Description

You are going to compute the area of a special kind of polygon. One vertex of the polygon is the origin of the orthogonal coordinate system. From this vertex, you may go step by step to the following vertexes of the polygon until back to the initial vertex. For each step you may go North, West, South or East with step length of 1 unit, or go Northwest, Northeast, Southwest or Southeast with step length of square root of 2.

For example, this is a legal polygon to be computed and its area is 2.5:

Input

The first line of input is an integer t (1 <= t <= 20), the number of the test polygons. Each of the following lines contains a string composed of digits 1-9 describing how the polygon is formed by walking from the origin. Here 8, 2, 6 and 4 represent North, South, East and West, while 9, 7, 3 and 1 denote Northeast, Northwest, Southeast and Southwest respectively. Number 5 only appears at the end of the sequence indicating the stop of walking. You may assume that the input polygon is valid which means that the endpoint is always the start point and the sides of the polygon are not cross to each other.Each line may contain up to 1000000 digits.
Output

For each polygon, print its area on a single line.
Sample Input

4
5
825
6725
6244865
Sample Output

0
0
0.5
2
Source

POJ Monthly–2004.05.15 Liu Rujia@POJ

題意:

給定一個多邊形,求多邊形面積

直接從原點開始用叉積求有向面積,中間不要取絕對值,最後取絕對值即可在*0.5即可
要主要不要存點,不然會MLE,還有不要開double,會損失精度,用longlong,最後判一下奇偶性即可

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
typedef long long LL;
const int maxn= 1e6+5;
LL ans;
int dx[10]={0,-1, 0, 1,-1, 0, 1,-1, 0, 1};
int dy[10]={0,-1,-1,-1, 0, 0, 0, 1, 1, 1};
char s[maxn];

int main()
{
  int T;
  scanf("%d",&T);
  while(T--)
  {
    scanf("%s",s+1);
    int n=strlen(s+1);
    if(n<=3)
    {
      printf("0\n");
      continue;
    }
    ans=0;
    int x=0,y=0,x1,y1,x2,y2;
    x1=x+dx[s[1]-'0'];
    y1=y+dy[s[1]-'0'];
    for(int i=2;i<n;++i)
    {
      x2=x1+dx[s[i]-'0'];
      y2=y1+dy[s[i]-'0'];
      ans+=x1*y2-x2*y1;
      x1=x2;
      y1=y2;
    }

    ans+=x1*y2-x2*y1;
    if(ans<0)ans=-ans; 
    if(ans&1)printf("%lld.5\n",ans>>1);
    else printf("%lld\n",ans>>1);
  }
  return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章