POJ 2051 Argus(按週期輸出)



Argus
Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 9674   Accepted: 4509

Description

A data stream is a real-time, continuous, ordered sequence of items. Some examples include sensor data, Internet traffic, financial tickers, on-line auctions, and transaction logs such as Web usage logs and telephone call records. Likewise, queries over streams run continuously over a period of time and incrementally return new results as new data arrives. For example, a temperature detection system of a factory warehouse may run queries like the following. 
Query-1: "Every five minutes, retrieve the maximum temperature over the past five minutes." 
Query-2: "Return the average temperature measured on each floor over the past 10 minutes."

We have developed a Data Stream Management System called Argus, which processes the queries over the data streams. Users can register queries to the Argus. Argus will keep the queries running over the changing data and return the results to the corresponding user with the desired frequency. 

For the Argus, we use the following instruction to register a query: 
Register Q_num Period

Q_num (0 < Q_num <= 3000) is query ID-number, and Period (0 < Period <= 3000) is the interval between two consecutive returns of the result. After Period seconds of register, the result will be returned for the first time, and after that, the result will be returned every Period seconds. 

Here we have several different queries registered in Argus at once. It is confirmed that all the queries have different Q_num. Your task is to tell the first K queries to return the results. If two or more queries are to return the results at the same time, they will return the results one by one in the ascending order of Q_num. 

Input

The first part of the input are the register instructions to Argus, one instruction per line. You can assume the number of the instructions will not exceed 1000, and all these instructions are executed at the same time. This part is ended with a line of "#". 

The second part is your task. This part contains only one line, which is one positive integer K (<= 10000). 

Output

You should output the Q_num of the first K queries to return the results, one number per line.

Sample Input

Register 2004 200
Register 2005 300
#
5

Sample Output

2004
2005
2004
2004
2005

Source



題目大意:

   這一題輸入數據每一行給你一個編號,再給你它每一次出現的間隔時間,最後以“#”結束,在末尾還有一個k,然後讓你根據他們出現的時間從早到晚把前k個編號打印出來,若在同一時間有多個編號,那麼先輸出小的編號。


解題思路:

優先隊列。


代碼:

#include<iostream>
#include<string>
#include<cstdio>
#include<queue>

using namespace std;
struct node{
	int Q_num;
	int Period;
	int nextTime;
	node(int Q_num0=0,int Period0=0,int nextTime0=0){
		Q_num=Q_num0,Period=Period0,nextTime=nextTime0;
	}
	friend bool operator < (node a,node b){
        if(a.nextTime!=b.nextTime) return a.nextTime > b.nextTime;
		return a.Q_num > b.Q_num;
	}

}Register;

priority_queue <node> pq;

int main(){
	string str;
	int Q_num;
	int Period;
	int t;
	while(cin>>str&&str!="#"){
		cin>>Q_num>>Period;
		Register.Q_num=Q_num;
		Register.Period=Period;
		Register.nextTime=Period;
		pq.push(Register);
	}
    cin>>t;
	//while(!pq.empty()) {cout<<pq.top().Q_num<<endl;pq.pop();}
	while(t--){
		Register=pq.top();
		cout<<Register.Q_num<<endl;
		Register.nextTime+=Register.Period;
		pq.pop();
		pq.push(Register);
	}
	return 0;
}


發佈了71 篇原創文章 · 獲贊 5 · 訪問量 6萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章