PAT-A1009題解


PAT-A1009. Product of Polynomials (25)
時間限制
400 ms
內存限制
65536 kB
代碼長度限制
16000 B
判題程序
Standard
作者
CHEN, Yue
This time, you are supposed to find A*B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 … NK aNK, where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, …, K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10, 0 <= NK < … < N2 < N1 <=1000.

Output Specification:

For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.

Sample Input
2 1 2.4 0 3.2
2 2 1.5 1 0.5
Sample Output
3 3 3.6 2 6.0 1 1.6


題目大意:讀入格式與A1002相同,不過這裏求的是多項式乘法


#include<cstdio>
struct poly{
    int exp;        //指數
    double cof;     //係數 
}poly[1010];
double answer[2010];
int main(){
    int k,count=0;
    scanf("%d",&k);
    for(int i=0;i<k;i++){
        scanf("%d %lf",&poly[i].exp,&poly[i].cof);
    }
    scanf("%d",&k);
    for(int i=0;i<k;i++){
        int exp;
        double cof;
        scanf("%d %lf",&exp,&cof);
        for(int j=0;j<k;j++){
            answer[exp+poly[j].exp]+=cof*poly[j].cof;
        }
    }
    for(int i=0;i<=2000;i++){
        if(answer[i]!=0.0)
            count++;
    }
    printf("%d",count);
    for(int i=2000;i>=0;i--){
        if(answer[i]!=0)
            printf(" %d %0.1f",i,answer[i]);
    }
    return 0;
} 

更多請查看個人博客:https://beatjerome.github.io

發佈了140 篇原創文章 · 獲贊 47 · 訪問量 6萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章