PAT-A1002題解


PAT-A1002. A+B for Polynomials (25)
時間限制
400 ms
內存限制
65536 kB
代碼長度限制
16000 B
判題程序
Standard
作者
CHEN, Yue
This time, you are supposed to find A+B where A and B are two polynomials.

Input

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 … NK aNK, where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, …, K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10,0 <= NK < … < N2 < N1 <=1000.

Output

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input
2 1 2.4 0 3.2
2 2 1.5 1 0.5
Sample Output
3 2 1.5 1 2.9 0 3.2


題目大意:題目很簡單,給你多項式項數,給出係數和冪次,進行兩個多項式的求和


AC代碼:

#include<cstdio>
int main(){
    double a[1010]={};
    int m,n;
    int e=0;
    double k;
    int count=0;
    scanf("%d",&m);
    while(m--){
        scanf("%d %lf",&e,&k);
        a[e]+=k;
    }
    scanf("%d",&n);
    while(n--){
        scanf("%d %lf",&e,&k);
        a[e]+=k;
    }
    for(int i=0;i<=1000;i++){
        if(a[i]!=0)
            count++;
    }
    printf("%d",count);
    for(int i=1000;i>=0;i--){
        if(a[i]!=0){
            printf(" %d %.1f",i,a[i]);
        }
    }
    return 0;
} 

更多請查看個人博客:https://beatjerome.github.io

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章