1003--最大子序列和,首尾結點

Problem Description

Given a sequence a[1],a[2],a[3]……a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.

Input

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).

Output

For each test case, you should output two lines. The first line is “Case #:”, # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.

Sample Input

2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5

Sample Output

Case 1:
14 1 4

Case 2:
7 1 6


解法1:

#include<stdio.h>

int main()
{
    int t,n,a[100005];
    int i,j,st,en,m,maxx,sum;
    int cas=1;

    scanf ("%d",&t);

    while (t--)
    {

        maxx = -1005;
        st = en = m = 1;
        sum = 0;

        scanf ("%d",&n);

        for (i=1; i<=n; i++)
        {
            scanf ("%d",&a[i]);

            sum += a[i];

            if (sum > maxx)
            {
                maxx = sum;
                st = m;
                en = i;
            }

            if (sum < 0)
            {
                sum = 0;
                m = i+1;
            }
        }

        printf ("Case %d:\n",cas++);
        printf ("%d %d %d\n",maxx,st,en);

        if (t)
        {
            printf ("\n");
        }

    }
    return 0;
}

解法2 :dp

#include<stdio.h>
#include<algorithm>
using namespace std;

int main()
{
    int t,cas=1,n;
    int a[100005],dp[100005]={0};
    int i,sum,st,en,maxx;
    int x,y;
    scanf ("%d",&t);

    while (t--)
    {
        scanf ("%d",&n);

        for (i=1; i<=n; i++)
        {
            scanf ("%d",&a[i]);
        }

        dp[1] = a[1];
        sum = 0;
        maxx = -100000;
        st = en = 1;

        for (i=1; i<=n; i++)
        {
            if (dp[i-1]+a[i] >= a[i])
            {
                dp[i] = dp[i-1] + a[i];
                en = i;
            }
            else
            {
                dp[i] = a[i];
                st = i;
                en = i;
            }

            if (dp[i] > maxx)
            {
                maxx = dp[i];
                x = st;
                y = en;
            }

        }

        printf ("Case %d:\n",cas++);

        printf ("%d %d %d\n",maxx,x,y);

        if (t)
        {
            printf ("\n");
        }
    }
    return 0;
}
發佈了41 篇原創文章 · 獲贊 0 · 訪問量 8097
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章