2018.1.21【POJ - 1328】小島與雷達解題報告(二維轉一維,貪心)

Radar Installation
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 96097   Accepted: 21364

Description

Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d. 

We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates. 
 
Figure A Sample Input of Radar Installations


Input

The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases. 

The input is terminated by a line containing pair of zeros 

Output

For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. "-1" installation means no solution for that case.

Sample Input

3 2
1 2
-3 1
2 1

1 2
0 2

0 0

Sample Output

Case 1: 2
Case 2: 1

Source


【題目大意】

給定二維平面N個點的座標作爲小島座標,給定雷達輻射半徑,求座標軸上放置雷達的最少個數。

【解題思路】

將小島在二維平面鐘的座標轉化爲一維座標軸上的線段也即數軸上的閉區間。兩個閉區間的交集表示可以同時輻射到這兩個小島的雷達可放置的區域。

由此,要使放置雷達的個數最少。將線段按左端點遞增排序,採用貪心策略,對於下一個小島能利用之前的雷達就利用,條件爲,下一條線段的左端點小於公用範圍(線段)右邊界。否則雷達+1,並以該線段作爲新雷達的公用範圍。

注意:1.共用範圍(線段)是不斷減小的,後一條線段的有端點大於共用範圍右端,則無影響,若小於右端,則新右邊界變爲該線段的右端點。

【解題代碼】

#include <cstdio>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <queue>
#define maxn 10010
using namespace std;
struct line
{
	double left;
	double right;
}island[10002];

bool cmp(struct line s1,struct line s2)
{
	return s1.left<s2.left;
}

int main()
{
//	freopen("in.txt", "r", stdin);
//    freopen("out.txt", "w", stdout);
	int ni,nd;
	scanf("%d%d",&ni,&nd);
	int count=0;
	while(ni||nd)
	{
	bool flag=false;
	for(int i=0;i<ni;i++)
	{
		double x,y;
		scanf("%lf%lf",&x,&y);
		if(y>nd)
			flag=true;
//		printf("x=%lf y=%lf\n",x,y);
		island[i].left=x-sqrt(nd*nd-y*y);
		island[i].right=x+sqrt(nd*nd-y*y);
	}
	if(flag)
	{
		printf("Case %d: -1\n",++count);
		scanf("%d%d",&ni,&nd);
	}
	else
	{
		sort(island,island+ni,cmp);
//		for(int i=0;i<ni;i++)
//			printf("island[%d] left=%lf right=%lf\n",i,island[i].left,island[i].right);
	int num=1;
	double minright=island[0].right;
	for(int i=0;i+1<ni;i++)
	{
		if(island[i+1].left<=minright)
		{
			if(island[i+1].right<minright)
			{
				minright=island[i+1].right;
			}
		}
		else
		{
			num++;
//			printf("num++\n");
			minright=island[i+1].right;
		}
	}
	printf("Case %d: %d\n",++count,num);
	scanf("%d%d",&ni,&nd);	
	}
	}
//	fclose(stdin);//關閉文件  
//    fclose(stdout);//關閉文件 
	return 0;
}

【收穫與反思】

二維問題轉一維問題需要學習一下。

發佈了40 篇原創文章 · 獲贊 1 · 訪問量 6258
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章