快速幂取模

原理:


相当于还是用了状态压缩。

B - A hard puzzle
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Description

lcy gives a hard puzzle to feng5166,lwg,JGShining and Ignatius: gave a and b,how to know the a^b.everybody objects to this BT problem,so lcy makes the problem easier than begin. 
this puzzle describes that: gave a and b,how to know the a^b's the last digit number.But everybody is too lazy to slove this problem,so they remit to you who is wise. 

Input

There are mutiple test cases. Each test cases consists of two numbers a and b(0<a,b<=2^30) 

Output

For each test case, you should output the a^b's last digit number. 

Sample Input

7 66
8 800

Sample Output

9
6


代码:

#include<bits/stdc++.h>
using namespace std;

int _pow(int a,int b)
{
    a%=10;
    int ans=1;

    while(b>0)
    {
        if(b&1) ans=ans*a%10;
        
        b>>=1;
        a=a*a%10;
    }
    return ans;
}

int main()
{
    int a,b;
    
    while(~scanf("%d%d",&a,&b))
    {
        printf("%d\n",_pow(a,b));
    }
    return 0;
}






发布了47 篇原创文章 · 获赞 43 · 访问量 7万+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章